LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-29-2008, 06:34 PM   #1
sehku17
LQ Newbie
 
Registered: Sep 2007
Location: St. Louis, MO
Distribution: Ubuntu & derivatives, Fedora
Posts: 19

Rep: Reputation: 0
Question trouble with VNC in gnome-rdp started through terminal via ssh (Xubuntu 7.10)


Here's the situation:

I have a web server (Xubuntu 7.10) with no monitor, and would like to configure certain utilities through the GUI, because it is more straightforward than through terminal. Right now I'm administering it through ssh, and using scp to transfer files. The obvious thing, I thought, was to put VNC on the machine (getting it through apt-get), and do it remotely, removing the need for a monitor. But when I start it, I get the message "(gnome-rdp:18110): Gtk-WARNING **: cannot open display: " I assume that this is because I am starting it through ssh, but I know that there is an X display running and XFCE4 can be seen through top and htop as being active, so it should be working. The man page for gnome-rdp is less than helpful in this regard, and I can't seem to find any solutions through the web either.

Have already tried vncserver, and that seems to run, but refused connection on trying to connect. Checked configuration, and ended up deciding that was out of the question. Just before someone suggests that.

Would appreciate any help I can get.
 
Old 05-01-2008, 05:18 PM   #2
lukost
Member
 
Registered: Apr 2008
Location: Gliwice, Poland
Distribution: Any. BSD most often ;-)
Posts: 31

Rep: Reputation: 15
ssh client does not enable X forwarding by default. Try connecting via:
ssh user@hostname -X

from X terminal (not the standard text console).

You can enable x forwarding by default in /etc/ssh/ssh-config (uncomment the x forwarding line and/or change 'no' to 'yes') or for a single user in his ./.ssh

cheers,
lukost
 
Old 05-01-2008, 06:47 PM   #3
sehku17
LQ Newbie
 
Registered: Sep 2007
Location: St. Louis, MO
Distribution: Ubuntu & derivatives, Fedora
Posts: 19

Original Poster
Rep: Reputation: 0
That got me what I needed, thanks a lot. Still haven't got RDP or VNC figured out, but with X-forwarding I can use the applications I want through the GUI, so no worries. Never knew X-forwarding could be done with normal ssh connection. Learn something new everyday.

Thanks again, that got the problem resolved enough for me.
 
  


Reply

Tags
remote desktop, vnc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
control backslash in gnome-terminal using vnc tibbitts Linux - Software 0 04-09-2008 04:34 PM
Is RDP as secure as SSH veeramani Linux - Security 3 03-12-2007 06:30 AM
Remote Desktop, ssh, vnc, rdesktop, RDP, cygwin? chbin Linux - Networking 7 12-17-2005 05:28 PM
Using WinXP to remotely control Linux box RDP? VNC? Fisslefink Linux - Networking 4 03-14-2005 12:38 AM
need VNC to allow 'logout/login' from Gnome (gnome & VNC runs fine) spudler Linux - Networking 3 11-14-2004 10:02 AM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration