LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   trouble with VNC in gnome-rdp started through terminal via ssh (Xubuntu 7.10) (http://www.linuxquestions.org/questions/linux-software-2/trouble-with-vnc-in-gnome-rdp-started-through-terminal-via-ssh-xubuntu-7-10-a-638761/)

sehku17 04-29-2008 07:34 PM

trouble with VNC in gnome-rdp started through terminal via ssh (Xubuntu 7.10)
 
Here's the situation:

I have a web server (Xubuntu 7.10) with no monitor, and would like to configure certain utilities through the GUI, because it is more straightforward than through terminal. Right now I'm administering it through ssh, and using scp to transfer files. The obvious thing, I thought, was to put VNC on the machine (getting it through apt-get), and do it remotely, removing the need for a monitor. But when I start it, I get the message "(gnome-rdp:18110): Gtk-WARNING **: cannot open display: " I assume that this is because I am starting it through ssh, but I know that there is an X display running and XFCE4 can be seen through top and htop as being active, so it should be working. The man page for gnome-rdp is less than helpful in this regard, and I can't seem to find any solutions through the web either.

Have already tried vncserver, and that seems to run, but refused connection on trying to connect. Checked configuration, and ended up deciding that was out of the question. Just before someone suggests that.

Would appreciate any help I can get.

lukost 05-01-2008 06:18 PM

ssh client does not enable X forwarding by default. Try connecting via:
ssh user@hostname -X

from X terminal (not the standard text console).

You can enable x forwarding by default in /etc/ssh/ssh-config (uncomment the x forwarding line and/or change 'no' to 'yes') or for a single user in his ./.ssh

cheers,
lukost

sehku17 05-01-2008 07:47 PM

That got me what I needed, thanks a lot. Still haven't got RDP or VNC figured out, but with X-forwarding I can use the applications I want through the GUI, so no worries. Never knew X-forwarding could be done with normal ssh connection. Learn something new everyday.

Thanks again, that got the problem resolved enough for me.


All times are GMT -5. The time now is 07:31 PM.