LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Trouble installing LaTeX texlive (http://www.linuxquestions.org/questions/linux-software-2/trouble-installing-latex-texlive-855024/)

abbotslad 01-08-2011 11:32 AM

Trouble installing LaTeX texlive
 
Hi there
I'm trying to install LaTeX on my laptop, but when I type this...

sudo apt-get install texlive

..all I get is an error message:

E: unable to locate package texlive

Can anyone help? I also need to install BiBTeX.
Thanks

knudfl 01-08-2011 12:54 PM

'sudo apt-get install texlive' is OK for :

10.10 Maverick, 10.04 Lucid, 9.10 Karmic, 8.04 Hardy.

Not for : 9.04 Jaunty, 8.10 Intrepid : They are not supported any more.

Which Ubuntu have you installed ?
http://www.linuxquestions.org/linux/...Ask_a_Question
http://linuxsilo.net/docs/smart-questions_en.html

The command : 'cat /etc/issue' will reply with a version.

..

abbotslad 01-09-2011 06:03 AM

Hi

I am running Ubuntu 10.10. So it should work?

knudfl 01-10-2011 02:49 AM

http://packages.ubuntu.com/maverick/texlive

Probably : sudo apt-get update && sudo apt-get install texlive


Or use the 'Refresh' button in Synaptic to update the package list.

..

b0uncer 01-10-2011 07:48 AM

I highly recommend obtaining texlive from the website instead of pulling it in from the Ubuntu reposities. I didn't check the latest (10.10) case, but at least in the previous (10.04) and older versions they only offered an old version of texlive, which is not what you want (meaning truly old, not just "the yesterday version"). Well, you may not notice it if you're lucky, but I was writing a book-ish thing at the time, and found a few problems with tables that could not be solved (sanely) without updating to a recent version.

Installing "semi-manually", by going to the aforementioned website, is not difficult (I'd say if you can run apt-get, you can do the installation from there as well, and you do find instructions for it). If you're just playing around with tex, go ahead with the Ubuntu reposity version, but else go for the latest (stable) version.


All times are GMT -5. The time now is 06:05 PM.