LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-18-2004, 10:36 AM   #1
froedi
Member
 
Registered: Nov 2003
Location: GER
Distribution: slackware 10.0
Posts: 62

Rep: Reputation: 15
Trouble building RAZOR


hey!

I've got spamassassin and want to use razor additionally. but I have troubles building it.

I've downloaded both, the razor-agents and the razor-agents-sdk sources.

when I do "perl Makefile.PL" for razor-agents-sdk, the output looks like this:
Code:
Warning: prerequisite Digest::SHA1 1 not found
Writing Makefile for Digest::HMAC
Testing alignment requirements for U32... /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/../../../../i486-slackware-linux/bin/ld: cannot find -ldb
collect2: ld returned 1 exit status
Can't compile test program
Writing Makefile for Digest::MD5
Writing Makefile for Digest::Nilsimsa
Writing Makefile for Digest::SHA1
Writing Makefile for MIME::Base64
Warning: prerequisite Digest::HMAC_MD5 1 not found.
Writing Makefile for Net::DNS
Writing Makefile for Test::Simple
[...]
why are Digest::SHA1 and Digest::HMAC_MD5 not recognized, although they are part of the package?

+ what does "cannot find -ldb" mean?

has anybody got an idea about how to fix this?


I have some trouble with razor-agents as well, but I guess it's because razor-agents-sdk hasn't been built properly. :/


thank you for your help. ;)
 
Old 01-22-2004, 11:00 PM   #2
thegreatnorth
LQ Newbie
 
Registered: Dec 2003
Location: Canada
Distribution: Fedora Core 1
Posts: 12

Rep: Reputation: 0
A better way would be NOT to use the SDK package
instead just install these packages straight from CPAN

In a terminal window: (using "su")

root@localhost# perl -MCPAN -e shell (if this is your first time type "no" to what it asks)
root@localhost# install Digest::SHA1 (this will install or update if needed)
root@localhost# install Digest::MD5 (and so on... you can do the same for each needed)

then build and install the razor-agents tarball
http://sourceforge.net/project/showf...?group_id=3978

then remember to run "razor-client"
and then "razor-admin -create" (as your normal user)

I'm not sure what the error you had meant though...
hope this helped.
 
Old 02-13-2004, 10:15 PM   #3
docbrazen
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware-current, Red Hat 9
Posts: 18

Rep: Reputation: 0
Iím having a similar problem. When I run perl Makefile.PL I get this error:
[root@**** razor-agents-2.36]# perl Makefile.PL
Warning: prerequisite Digest::SHA1 0 not found.
Writing Makefile for Razor2::Preproc::deHTMLxs
Writing Makefile for razor-agents


I tried installing Digest::SHA as suggested but it says it is up to date.
cpan> install Digest::SHA1
Digest::SHA1 is up to date.


I'm running Redhat 9 and I did the /etc/sysconfig/i18n file fix, changing the "LANG" value from "en_US.UTF-8" to "en_US".
 
Old 02-13-2004, 10:34 PM   #4
docbrazen
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware-current, Red Hat 9
Posts: 18

Rep: Reputation: 0
Quote:
Originally posted by docbrazen
Iím having a similar problem. When I run perl Makefile.PL I get this error:
[root@**** razor-agents-2.36]# perl Makefile.PL
Warning: prerequisite Digest::SHA1 0 not found.
Writing Makefile for Razor2::Preproc::deHTMLxs
Writing Makefile for razor-agents


I tried installing Digest::SHA as suggested but it says it is up to date.
cpan> install Digest::SHA1
Digest::SHA1 is up to date.


I'm running Redhat 9 and I did the /etc/sysconfig/i18n file fix, changing the "LANG" value from "en_US.UTF-8" to "en_US".
For some reason I had to delete all my SHA1.pm, SHA1.bs, and SHA1.so files and reinstall to fix it.

Now I just need to get spamassassin to install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble building kxdocker 0.20 mauripop Linux - Software 2 04-20-2005 01:59 PM
Having trouble building and installing GTK+ Plz Help! Gormless Linux - Software 5 10-10-2004 09:26 PM
Trouble building the aterm RPM ?? WhiteTornado Fedora 3 03-23-2004 02:38 AM
Trouble Building Bison Parser exitsfunnel Programming 1 12-09-2003 06:14 PM
trouble building latest gnome vance Linux - Software 1 02-10-2003 01:18 PM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration