LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   trouble ahead, trouble behind....trouble with mplayer (http://www.linuxquestions.org/questions/linux-software-2/trouble-ahead-trouble-behind-trouble-with-mplayer-69237/)

Goonie 07-01-2003 03:27 AM

trouble ahead, trouble behind....trouble with mplayer
 
I am having some issues with mplayer. I have the latest source, installed and all, but I am unable to get the GUI working. I downloaded a theme, Neutron specifically, and tarred it into the /usr/local/share/mplayer/Skin/ directory, created a default directory, and a skin directory within that, and then created a link of the neutron folder inside the default folder...all these were directions I read on a previous post relating to this...this is what I get now after running gmplayer:
-----------------------------------------
[guest@localhost guest]$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Ste
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpude
Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file o
ry
Reading config file /home/guest/.mplayer/config
[cfg] read config file: /home/guest/.mplayer/gui.conf
Reading config file /home/guest/.mplayer/gui.conf: No such file or dire
vo: X11 running at 1152x864 with depth 16 and 16 bpp (":0.0" => local d
Disabling DPMS
Reading /home/guest/.mplayer/codecs.conf: can't open '/home/guest/.mpla
s.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/guest/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system
scripts.
Using usleep() timing
Can't open input config file /home/guest/.mplayer/input.conf : No such
irectory
Can't open input config file /usr/local/etc/mplayer/input.conf : No suc
directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/guest/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

---------------------------------------------

and then it just stays blank, as if the program is running, but I can't see anything. When I do a ctrl-c to kill it, a window pops up and says "mplayer interrupted by signal 2 in module : unknown"

What is wrong with my mplayer?

MasterC 07-01-2003 03:34 AM

Easiest way I'd suggest going about this:

First off, you'll need a Font, it appears you don't have one setup.

Second, it's easiest, I find, to grab the "default" font from Mplayer, use it as the default, then download others and use the gmplayer tool to switch (in the preference I think).

Cool

Goonie 07-02-2003 12:14 AM

I downloaded a font from the mplayer website, an arial font pack, the only one I could find actually...it untars into like 10 directories of different font sizes, so i copied all the arial18 font files to the /usr/local/share/mplayer/font/ directory, and it detects them on the startup, but still no mplayer. Same result as before...here is my updated log:

-----------------------------------------
[root@localhost cp1250]# gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1152x864 with depth 16 and 16 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (233 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

--------------------------------

Exact same result as before, mplayer is running, but I can't see anything...

Matt

MasterC 07-02-2003 02:29 AM

Try using the actual "Default" skin first, then switch after that is working. It's easiest to troubleshoot a problem that way :)

Cool


All times are GMT -5. The time now is 10:34 AM.