LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-30-2003, 07:35 PM   #1
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
triple boot with lilo(two linux and XP)


ok...so finally i come to the forum....i have been looking around for quiet some time and i havent been able to find a solution...
i have tow hard disks....on one of them i have Win XP and Knoppix installed and on the other....i just installed Slackware 9.1
Now using lilo i can boot up just fine into Slackware and XP...but i have problems booting into knoppix.
i did add something to lilo.conf in slackware but when i hit enter to that label...it does start booting up knoppix but then after a while it says kernel panic and stops doing anything at which point i have to reboot the computer.
could you please tell me what to add to lilo.conf to make this work...plz let me know if you want me to post my lilo.conf file here.
thanks
 
Old 11-30-2003, 07:47 PM   #2
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
So the thing says 'Kernel Panic' and ... ? Elaborate. I'm guessing that you forgot the 'root' line in lilo.conf for knoppix:
root=/dev/[disk]
Make sure you specify the right disk for Knoppix.
 
Old 11-30-2003, 07:49 PM   #3
vnsullivan
LQ Newbie
 
Registered: Nov 2003
Posts: 15

Rep: Reputation: 0
In general, the main problem when you install two Linux distros is that one must have lilo installed in the MBR (the one which deals boot time), and the other must have lilo installed at the begining of its partition.
 
Old 11-30-2003, 07:52 PM   #4
vnsullivan
LQ Newbie
 
Registered: Nov 2003
Posts: 15

Rep: Reputation: 0
Quote:
Originally posted by vnsullivan
In general, the main problem when you install two Linux distros is that one must have lilo installed in the MBR (the one which deals boot time), and the other must have lilo installed at the begining of its partition.
Didn't see you installed the two distros on two different drives...
What I said is for a one HD install.
I guess there's no problem with a two disks install .
 
Old 11-30-2003, 07:55 PM   #5
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
one must have lilo installed in the MBR (the one which deals boot time), and the other must have lilo installed at the begining of its partition.
Linuxes can use the same bootloader. The main problem is special features the distros may have added; the graphical splash screens other distros use may not work with Slackware's version of lilo. But Slack lilo can still boot other distros, just without the splash screen.
 
Old 03-20-2004, 02:34 AM   #6
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
Unhappy How to edit lilo.conf for Win + 2 linuxes?

Another newbie. I want to make lilo boot into two linuxes plus windows. This is my setup: WindowsME - hda0 (the original OS), Mandrake 9.1 - hdb1, Fedora core 1 - hda3 (installed after Mandrake). Hda2 is a tiny partition the Fedora installer insisted on putting on hda, and is empty. Lilo will boot fine into Windows or Mandrake but hangs on booting into Fedora. Fedora boots fine from the boot diskette, but that's clunky.

This is (was) my /etc/lilo.conf file:

boot=/dev/hda
map=/boot/map
vga=normal
default="linux-Mandrake"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux-Mandrake"
root=/dev/hdb1
initrd=/boot/initrd.img
append="quiet devfs=mount hdd=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="linux-Fedora"
root=/dev/hda3
initrd=/boot/initrd.img
append="quiet devfs=mount hdd=ide-scsi acpi=off"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hdb1
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi acpi=off"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdb1
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdd=ide-scsi acpi=off"
read-only

I made the Fedora portion of lilo.conf by copying the entry from Linux-Mandrake to Linux-Fedora, changing the root= to hda3. I also tried doing it in Mandrake's control center. When I reboot and try to select Fedora, the Mandrake boot loader splash comes up and it tries to do Fedora but gets part-way and hangs. Once kudzu appeared and wanted me to do away with my cdrom2, at which I deleted the fedora portion of lilo.conf and rebooted into Mandrake.

How do I edit lilo.conf to boot Fedora too? What if I want to install a third linux... how do I edit lilo.conf?

In faith, Dave
dave@christos.cjb.net
Viva Texas
 
Old 03-22-2004, 07:58 AM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You are trying to load Fedora with the Mandrake kernel. They are slightly different. You will need to find the Fedora kernel, which might be somewhere in the Fedora partitions. If the hda2 is Fedora's /boot partition, then it is in there. If there is no /boot partition, then it is in the Fedora's main partition. to use lilo for the Fedora kernel, you will need to mount the partition it's in (in Mandrake, as root):
mkdir /mnt/fedora
mkdir /mnt/fedoraboot for if the hda2 is /boot
mount /dev/hda2 /mnt/fedoraboot see above
mount /dev/hda3 /mnt/fedora

Now the partitions are mounted at /mnt/fedora and /mnt/fedoraboot . the path to the kernel will be (one of these):
/mnt/fedora/boot/[kernel image name]
/mnt/fedoraboot/[kernel image name]

Browse in your Fedora partitions to find the exact name. It will most likely be 'vmlinuz-[some numbers]'. Then add it to your lilo.conf:
image=/path/to/fedora/kernel
Run 'lilo' to apply changes.
 
Old 03-22-2004, 10:18 AM   #8
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
You might want to consider using XP's "ntldr". Write Lilo to the root partitions on your different Linux distros and build a file with "dd if=/dev/hda/? of=/bootsect.slk bs=512 count=1" (.slk is what I use for Slackware. .deb,.mdk etc..) Copy this file to C:\ and add C:\bootsect.slk="Slackware" to your boot.ini. If you place a shortcut from your kernel image to / instead of /boot and edit your lilo.conf it will boot straight to the kernel and past the annoyance of two boot screens.
 
Old 03-22-2004, 01:51 PM   #9
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
There will only be one boot screen, the Mandrake boot screen.
 
Old 03-24-2004, 01:17 AM   #10
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
How to edit lilo.conf for Win + 2 linuxes?

First, Allen, I don't have XP and don't plan to get it so the ntldr option won't work for me. Thanks anyway.

Next, aaa, thanks for the response. My hda2 is empty; I don't know why fedora's installer insisted on making it, but hda3 is where fedora is loaded. vmlinuz-2.4.22-1.2174.nptl is loaded in /boot of hda3. Also, I already installed /mount/fedora and can see (and push stuff into) the fedora partition from mandrake - but of course in mandrake I can't retrieve anything from fedora.

So, right now the fedora portion of my lilo.conf reads:

image=/boot/vmlinuz
label="linux-Fedora"
root=/dev/hda3
initrd=/boot/initrd.img
append="quiet devfs=mount hdd=ide-scsi acpi=off"
vga=788
read-only

I'm assuming I only need to change the line reading image=/boot/vmlinuz to read image=/boot/vmlinuz-2.4.22-1.2174.nptl ???

Do I need to change anything else? For example, I notice there's no initrd.img in fedora's /boot, but there is an initrd-2.4.22-1.2174.nptl. Do I need to change that line as well?

I also want to install damnsmall linux; will I go through a similar process to get it into my mandrake lilo.conf?

In faith, Dave
dave@christos.cjb.net
Viva Texas
 
Old 03-24-2004, 08:02 AM   #11
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
I'm assuming I only need to change the line reading image=/boot/vmlinuz to read image=/boot/vmlinuz-2.4.22-1.2174.nptl ???
This is the Mandrake lilo.conf, right? To do that, you will have to copy the Fedora kernel image to the Mandrake partition. Or, you can put:
image=/mnt/fedora/boot/vmlinuz-2.4.22-1.2174.nptl
You may need the Fedora initrd, you can try with out it if you want.
It should be somewhat like this in the end:
Code:
#assumes you copied the kernel from Fedora to your Mandrake
image=/boot/vmlinuz-2.4.22-1.2174.nptl
#below, if you didn't copy and have the Fedora mounted at /mnt/fedora
#image=/mnt/fedora/boot/vmlinuz-2.4.22-1.2174.nptl
label="linux-Fedora"
root=/dev/hda3
#again, if you copied the initrd file to the Mandrake partition
initrd=/boot/initrd-2.4.22-1.2174.nptl
#for straight from fedora partition:
#initrd=/mnt/fedora/boot/initrd-2.4.22-1.2174.nptl
#here are some options, remove some if they cause trouble
#quiet - tells kernel not to spew tons of messages at boot
#devfs=mount - mounts devfs filesystem
#hdd=ide-scsi - use scsi emulation for hdd (possibly a cdrw)
#acpi=off - make sure acpi power management is off
#vga=788 - sets resolution at bootup
#read-only - mount root fs read-only (you need this)
append="quiet devfs=mount hdd=ide-scsi acpi=off"
vga=788
read-only
Remeber to run 'lilo' to apply changes.
 
Old 03-24-2004, 02:38 PM   #12
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
OK, I think I got that, and maybe even understand. Wouldn't I rather leave my fedora kernel in fedora? So, I'll copy this to the mandrake lilo.conf:

image=/mnt/fedora/boot/vmlinuz-2.4.22-1.2174.nptl
label="linux-Fedora"
root=/dev/hda3
initrd=/mnt/fedora/boot/initrd-2.4.22-1.2174.nptl
append="quiet devfs=mount hdd=ide-scsi acpi=off"
vga=788
read-only

I guess this all adds up to telling lilo how to find the kernel and operating file in fedora starting from mandrake. I hadn't realised my lilo starts from mandrake; I thought lilo was a completely separate thing which could point to either.

One thing I don't understand the necessity of: booting in read-only mode. I notice mandrake does that and then changes to read-write, but what's the purpose?

In faith, Dave
dave@christos.cjb.net
Viva Texas
 
Old 03-24-2004, 02:42 PM   #13
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
For filesystem checking. Don't want to check the filesystem and write at the same time, it could cause problems.
 
Old 03-24-2004, 02:45 PM   #14
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
OK, I see that. Thanks. I'll click Affero!

In faith, Dave
dave@christos.cjb.net
Viva Texas
 
Old 03-24-2004, 03:22 PM   #15
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
Whooops! Eveb with yopur help so far, I'm not there yet. When I installed fedora, grub was made my bootloader. Then, I used the mandrake install cd to update and lilo was reinstalled. Later I had to reinstall fedora so grub is back in place and I'm booting mandrake from the boot floppy.

When I became root in mandrake's console, I typed "lilo" and received this message:

Warning: /etc/lilo.conf should be writable only for root
Added linux-Mandrake *
Fatal: Trying to map files from unnamed device 0x000b (NFS ?)

I tried to update mandrake again to reinstall lilo; mandrake's lilo.conf has been changed to show the new info re fedora; I became root, typed lilo, and received the same error message. Grub is still my bootloader. How do I make lilo the loader?

In faith, Dave
dave@christos.cjb.net
Viva Texas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo triple boot mngmd Linux - General 5 11-20-2005 07:55 PM
Can LILO allow me to triple boot? captaincaveman Linux - Distributions 1 05-03-2004 07:22 PM
Triple Boot with Lilo MaleWithBrains Linux - Software 6 02-10-2004 08:39 AM
need help with lilo and triple boot! rmanocha Linux - Software 1 11-02-2003 02:51 AM
Triple Boot w/Lilo zuele Linux - Software 1 10-09-2003 07:02 PM


All times are GMT -5. The time now is 09:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration