LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-13-2005, 01:09 AM   #1
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Rep: Reputation: 15
Totem wont allow other programs to make audio output


Hey all,
I've been running all my mp3's from totem for the past couple of weeks, but I have the following problem: while it's playing, other programs, like gaim, can't make the sounds they're supposed to. I know that totem CAN allow this if it's working properly, because it happened once (which is weird in itself). Essentially I want one of two solutions:

I) Some way to fix totem (or whatever is causing the bug) so that it will allow for concurrent sounds to play, or
II) An alternate music/media player that won't give this problem. I've been thinking about getting amarok, but I don't know if this is the best choice or not.

Any help will be much appreciated.

Steve
 
Old 03-13-2005, 03:36 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try configuring Totem to use the alsa sound system.
 
Old 03-13-2005, 03:07 PM   #3
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks for the suggestion reddazz,
Unfortunately I haven't the faintest idea how to do that.
Some instructions of what commands to try would be greatly appreciated.
Thanks,

Steve
 
Old 03-13-2005, 03:21 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Unfortunately I am stuck on a machine using KDE, so I can't give you an accurate answer. Start Totem and I am sure there is a preferences menu somewhere. Change the sound system/server to alsa in the xine audio preferences.
 
Old 03-18-2005, 08:09 PM   #5
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Original Poster
Rep: Reputation: 15
hmmm, I have checked the preferences menu and the audio only gives the option of Stereo, 4.1 Surround, 5.1 Surround, and AC3Passthrough. Clearly this is not any kind of xine audio preferences menu. None of the other tabs are anything remotely helpful either. Clearly the way to set up totem to play through ALSA is not here.
Any other suggestions are very much welcome,

Steve
 
Old 03-18-2005, 09:00 PM   #6
mandavi
LQ Newbie
 
Registered: Nov 2004
Location: berlin
Distribution: ubuntu 6.06
Posts: 21

Rep: Reputation: 15
As far as I know Totem is just a back-end for the xine engine. You might want to try changing xine to ALSA and see what happens. For that you have to change the "experience level" in the "gui"-part of the preferences to "advanced" first and than go to the audio section. Than go to "audio driver to use" and select "alsa"

good luck
 
Old 03-23-2005, 01:25 AM   #7
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks for the suggestion mandavi, but I can't seem to find any kind of "experience level" option anywhere. Maybe this isn't available on the version i'm running? I just checked and I'm running version 0.99.9 with xine-lib version 1.0.0 If you have any guesses as to why I can't find these options, please let me know. As always, all suggestions are appreciated.

Steve
 
Old 04-08-2005, 11:36 AM   #8
AlphaZviftION
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
Try this. It will work if your xine uses the gstreamer backend anyway.
run
Code:
gstreamer-properties
You will get some dialogs. Try changing the output input in audio to alsa. You need the dmix plugin installed By the way. So if this doesn't work it might be using the xine backend so u would have to confidure xine or configure dmix for alsa properly.
 
Old 04-08-2005, 07:31 PM   #9
osbie
Member
 
Registered: Jul 2004
Location: Los Angeles (the Great Cultural Wasteland)
Distribution: SuSe 10.2
Posts: 151

Rep: Reputation: 30
look in your home directory /home/your-user-name/ for a '.' file i.e. - .totem or .xine, the config file is there. look for the default snd device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Totem, Xine, ... no audio D-Vine Linux - Software 3 09-20-2005 01:03 PM
Go Open Source episodes - no audio in vlc, totem, mplayer prara Mandriva 1 07-23-2005 06:07 AM
Totem or totem gstreamer wont decode quicktime or wmv movies! reformedgeek Ubuntu 5 05-24-2005 12:13 PM
Make Totem use esound Haiyadragon Linux - Software 0 09-18-2004 10:02 AM
totem media player wont operate sammy2299 Linux - General 1 08-18-2004 05:54 PM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration