LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-16-2010, 10:48 AM   #1
esteeven
Senior Member
 
Registered: Oct 2001
Location: Bristol UK
Distribution: Arch Ubuntu Slackware
Posts: 1,028

Rep: Reputation: 42
toolbar buttons missing (but fixed) in Openoffice


In Slackware 13.1, my OpenOffice menu buttons did not appear after installing the Slackbuild from slackbuild.org. I think this is a common issue. After reading around, I put

Code:
export OOO_FORCE_DESKTOP=kde
into my /etc/profile. OpenOffice now opens fine and all the menu button icons are present and correct but this only happens if I start OO from the CLI. This is fine for me but other users of this system will use the kicker menu. The problem is that this starts OpenOffice with no toolbar buttons. How can I apply

Code:
export OOO_FORCE_DESKTOP=kde
to my menu buttons?

Thanks
 
Old 08-17-2010, 02:29 AM   #2
esteeven
Senior Member
 
Registered: Oct 2001
Location: Bristol UK
Distribution: Arch Ubuntu Slackware
Posts: 1,028

Original Poster
Rep: Reputation: 42
Hmmm. I also have the same issue on my KDE4 Debian box. The solution is the same : if I input
Code:
export OOO_FORCE_DESKTOP=kde
in a terminal and then run oowriter from the CLI, everything is okay.

I have just been playing on my Debian box and added
Code:
export OOO_FORCE_DESKTOP=kde
to /etc/openoffice/sofficerc and my toolbars work!

edit: I will test on the Slackware box later.
 
1 members found this post helpful.
Old 08-17-2010, 02:57 AM   #3
esteeven
Senior Member
 
Registered: Oct 2001
Location: Bristol UK
Distribution: Arch Ubuntu Slackware
Posts: 1,028

Original Poster
Rep: Reputation: 42
Results in Slackware:

I edited sofficerc in /opt/openoffice.org3/program and added the line

Code:
export OOO_FORCE_DESKTOP=kde
and all is well so far.
 
1 members found this post helpful.
  


Reply

Tags
buttons, openoffice.org, toolbar


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] thunar toolbar buttons/icons are really huge ichundu Linux - Software 6 09-18-2011 10:34 PM
LXer: Custom Toolbar Buttons for Thunderbird LXer Syndicated Linux News 0 12-03-2009 12:21 AM
Openoffice toolbar problem dajomu Linux - Software 3 08-16-2006 01:16 AM
toolbar colors in acroread and openoffice eccarlsen Linux - General 0 10-25-2002 01:03 PM
My toolbar is gone, I cannot print to a remote printer, and lose my OpenOffice?? jahen8 Linux - Software 1 10-10-2002 10:39 AM


All times are GMT -5. The time now is 05:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration