LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Tomcat 5 on RHL , PLEASE HELP!!!!!!!!! (http://www.linuxquestions.org/questions/linux-software-2/tomcat-5-on-rhl-please-help-231946/)

zgiv 09-17-2004 05:45 PM

Tomcat 5 on RHL , PLEASE HELP!!!!!!!!!
 
Hey dudes,

heres my problem .
1.Red Hat 8.0
2.Tomcat 5.5.2 alpha base distro only
3.Java2 SDK 1.4.2
4. Mozilla 1.7.3

everything is set
1. Tomcat 5.5.2 is installed and integated to use JAVA 1.4.2
( Catalina_home , Java_home all reflect the appropriate directories)

2. Mozilla has been configured to use JRE 5

./startup.sh starts Tomcat 5 ( no error or warning messages)
./shutdown.sh stops Tomcat 5 ( no error or warning messages)

Yet after tomcat starts , when i type in 127.0.0.1:8080 or localhost:8080
it simple keeps giving me this error-----> " the connection was refused when attempting to contact ...", i even tried connecting from a different machine using the orginal IP ADDY...that too gives teh same error...

WHAT AM I DOING WRONG???this is my first trial with tomcat ...i tried reading all that i could!!!!!

am i supposed to have a httpd runnning on the machine since i am assuming and read that tomcat itself works as a webserver!

i even checked /etc/rc.d/rcsysint ../network.../hosts all reflect localhost!!!
i even pinged ..that works too!!!!


PLEASE PLEASE SOMEONE HELP ME !!!!!!!

peace dudes!

jandersen78 09-27-2004 11:29 PM

Does the catalina.out or catalina.log file in <tomcat home>/logs add any useful information? It sounds like tomcat isn't up and running, maybe there's some error that's getting logged but not output to the console.

ardee 10-19-2004 01:21 PM

Have you checked on the proxy server settings?
 
I also had encountered that problem, and I found out that I have not put "localhost" or "127.0.0.1" under the "No proxy" list. Note that my PC is inside a network and connects through the internet via a proxy server. It seems that the resolution of the address (this includes 127.0.0.1) was done by the proxy server, and not my machine.

I don't know about Mozilla, but right now I am using firefox 0.8. I hope that the interface would be similar. If not, this is usually found somewhere near proxy settings tab.

To put 127.0.0.1 under the "No proxy" list in firefox 0.8:

Tools -> Options -> General -> Connection Settings -> No Proxy for:


Then put "127.0.0.1,localhost" on the text box (without the quotes).

Tell me if it works :)

UsualTuxpect 10-19-2004 03:48 PM

what does #netstat -a | grep :8080

say

check if ur comp listening on 8080 [i mean can u see the port 8080]


All times are GMT -5. The time now is 05:33 AM.