LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   tmux crashes on exit (http://www.linuxquestions.org/questions/linux-software-2/tmux-crashes-on-exit-878632/)

portia 05-03-2011 05:19 PM

tmux crashes on exit
 
I'm running Slackware 64 13.37.

Whenever I type 'exit' in tmux in order to exit it, tmux freezes and I have to close the terminal to get rid of it (and then kill -9 tmux zombie processes). I tried it on sakura, urxvt, konsole.

my .bashrc is:
Code:

. /etc/profile

#if [ -f /etc/bashrc ]; then
#        . /etc/bashrc
#fi

# CFLAGS
CHOST="x86_64"
export CFLAGS="-march=native -O2 -pipe -fPIC"
export CXXFLAGS="${CFLAGS}"
export PATH=$PATH:~/bin
export MAKEFLAGS="-j7"



my ~/.tmux.conf

Code:


set utf8-default on
unbind-key C-b
set-option -g prefix C-a

unbind %
bind | split-window -h
bind - split-window -v

unbind C-b
set -g prefix C-a
set-window-option -g utf8 on
set -g set-titles on
set -g set-titles-string "#I) #W"
# default statusbar colors
set -g status-fg white
set -g status-bg black
set -g status-attr default
# default window title colors
set-window-option -g window-status-fg white
set-window-option -g window-status-bg black
set-window-option -g window-status-attr dim
# active window title colors
set-window-option -g window-status-current-fg white
set-window-option -g window-status-current-bg default
set-window-option -g window-status-current-attr bright
# command/message line colors
set -g message-fg white
set -g message-bg black
set -g message-attr bright
set -g status-left "#[fg=white,bg=black,bright]#H #[default,fg=white,bg=black]|#[default]"
set -g status-left-length 12
set -g status-right "#[default,fg=white,bg=black]|#[fg=white,bg=black,bright]%a %d.%m %H:%M#[default]"
set -g status-right-length 50

I happily used tmux on previous slackware versions.

portia 05-05-2011 03:11 PM

Anyone? Can it be something to do with type of terminal?

xhack 06-11-2011 01:40 PM

Sorry. I know this thread is a few weeks old but I'm sure we're not the only ones to have run into this. The tmux from slackbuilds for 13.37 uses libevent2, which is frankly buggy. To get tmux working I went back to libevent 1.4 and it works perfectly.

Just to clarify.I have libevent 1.4 and tmux built in /usr/local. There are other slackbuilds that require libevent2 and wont build against 1.4


All times are GMT -5. The time now is 04:44 AM.