LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Thunar can't mount (http://www.linuxquestions.org/questions/linux-software-2/thunar-cant-mount-785596/)

MTK358 01-29-2010 09:06 AM

Thunar can't mount
 
I am using Xfce, and so the Thuner file manager. But I have a problem: When I plug in an external storage device (like my flash drive), I get the error in a diaglog box (shown in attachment). The only option I have is to manually mount is with the command line.

How to fix this?

HasC 01-29-2010 09:44 AM

Do you have the command "exo-mount" on your system?

business_kid 01-29-2010 09:56 AM

Don't mount automagically here either, but that suits my tastes. I tried 'exo-mount -d /dev/sdb1' and get this

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal").

'This sender' is a luser, not root. When I try that with a sudo in an xterm, all is well. But try it from Thunar with the perms for exo-mount at 4711, and GTK complains about running as root.

Methinks you'll have to drive a coach & four through your security policies. Read up on Hal, and you might do it neatly.

MTK358 01-29-2010 10:11 AM

Quote:

Originally Posted by business_kid (Post 3844925)
Don't mount automagically here either, but that suits my tastes. I tried 'exo-mount -d /dev/sdb1' and get this

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal").

'This sender' is a luser, not root. When I try that with a sudo in an xterm, all is well. But try it from Thunar with the perms for exo-mount at 4711, and GTK complains about running as root.

Methinks you'll have to drive a coach & four through your security policies. Read up on Hal, and you might do it neatly.

I hardly understand any of that.

business_kid 01-30-2010 04:10 AM

Sorry.

I have the same setup and usb disks don't mount automatically. I don't consider that a problem.

You have to be able to mount them as a user before you can mount them as a user using xfce.

Either that, or change the security policies in gtk or hal, and on the system

MTK358 01-30-2010 08:09 AM

Quote:

Originally Posted by business_kid (Post 3845804)
Either that, or change the security policies in gtk or hal, and on the system

How would you do that?

I guess it's OK to manually mount, but it would be convenient if Thunar would do it, or at least not bother me with that error when it can't.

MTK358 01-30-2010 08:36 AM

Also, how can you make a normal user add/remove files from the mounted device?

business_kid 01-31-2010 03:57 AM

It can be a bit tiresome. I simply use sudo mount <options>
Other things: Enter them in /etc/fstab and enter either
1. user, or users options - for details see man fstab
2. With vfat disks, you can specify uid and gid for your user and group. Then _you_ and not other users can write.
3. RTFM if you want to startt changing Hal.Google "hal site:freedesktop.org"


All times are GMT -5. The time now is 08:27 AM.