LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-29-2010, 08:06 AM   #1
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Thunar can't mount


I am using Xfce, and so the Thuner file manager. But I have a problem: When I plug in an external storage device (like my flash drive), I get the error in a diaglog box (shown in attachment). The only option I have is to manually mount is with the command line.

How to fix this?

Last edited by MTK358; 03-26-2010 at 04:18 PM.
 
Old 01-29-2010, 08:44 AM   #2
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
Do you have the command "exo-mount" on your system?
 
Old 01-29-2010, 08:56 AM   #3
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,489

Rep: Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566
Don't mount automagically here either, but that suits my tastes. I tried 'exo-mount -d /dev/sdb1' and get this

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal").

'This sender' is a luser, not root. When I try that with a sudo in an xterm, all is well. But try it from Thunar with the perms for exo-mount at 4711, and GTK complains about running as root.

Methinks you'll have to drive a coach & four through your security policies. Read up on Hal, and you might do it neatly.
 
Old 01-29-2010, 09:11 AM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Original Poster
Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Quote:
Originally Posted by business_kid View Post
Don't mount automagically here either, but that suits my tastes. I tried 'exo-mount -d /dev/sdb1' and get this

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal").

'This sender' is a luser, not root. When I try that with a sudo in an xterm, all is well. But try it from Thunar with the perms for exo-mount at 4711, and GTK complains about running as root.

Methinks you'll have to drive a coach & four through your security policies. Read up on Hal, and you might do it neatly.
I hardly understand any of that.
 
Old 01-30-2010, 03:10 AM   #5
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,489

Rep: Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566
Sorry.

I have the same setup and usb disks don't mount automatically. I don't consider that a problem.

You have to be able to mount them as a user before you can mount them as a user using xfce.

Either that, or change the security policies in gtk or hal, and on the system
 
Old 01-30-2010, 07:09 AM   #6
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Original Poster
Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Quote:
Originally Posted by business_kid View Post
Either that, or change the security policies in gtk or hal, and on the system
How would you do that?

I guess it's OK to manually mount, but it would be convenient if Thunar would do it, or at least not bother me with that error when it can't.
 
Old 01-30-2010, 07:36 AM   #7
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Original Poster
Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Also, how can you make a normal user add/remove files from the mounted device?
 
Old 01-31-2010, 02:57 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,489

Rep: Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566
It can be a bit tiresome. I simply use sudo mount <options>
Other things: Enter them in /etc/fstab and enter either
1. user, or users options - for details see man fstab
2. With vfat disks, you can specify uid and gid for your user and group. Then _you_ and not other users can write.
3. RTFM if you want to startt changing Hal.Google "hal site:freedesktop.org"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] thunar stopped to mount USB storages (Debian squeeze) kaz2100 Debian 11 09-27-2011 02:21 AM
[SOLVED] Using ffmpegthumbnailer in thunar TOTALZERO Slackware 4 01-17-2010 01:32 AM
Thunar, FluxBox & auto mount CopyrightPhilly Linux - Software 1 05-14-2009 01:06 PM
nautilus or thunar freeze when nfs mount not available nephish Linux - Software 6 12-31-2008 04:13 PM
is Thunar the only solution? tiberian Linux - Newbie 7 06-12-2008 09:51 PM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration