LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-22-2004, 09:12 PM   #1
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Rep: Reputation: 15
System Halting while shutdown system.


Dear All,
I'm using RH ES3.0 Kernel 2.4.21-4.ELsmp #1 SMP Fri Oct 3 17:52:56 EDT 2004 i686 i686 i386 GNU/Linux
I've a little problem.
My problem is,
Once I send command "shutdown -r now" in CLI.
The system will be shuting down process.
It looks good.
But It'll be frozen on "System Halting" line.
I've to come at Server then put the power button for power off it.
My aim that i don't want to come at system everyday to turn it off
Because it's remote system.
Anybody ever encounter this problem??

Please kindly get me out.

Regards,
 
Old 12-23-2004, 02:45 AM   #2
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Sounds like you need either APM or something to shut it off. Mine uses APM. It depends on the mobo though. May need to search for your mobo model and apm in www.google.com/linux and see what others use.

I bet that is a bummer though.

Later

 
Old 12-23-2004, 02:53 AM   #3
daihard
Member
 
Registered: Jul 2003
Location: Lynnwood, WA
Distribution: Kubuntu 10.10
Posts: 912

Rep: Reputation: 32
I'm sure it's a typo, but let's just make sure we are talking about "shutdown -h now" here.

You can type "apm -v" to see if your BIOS/kernel supports APM. If it comes back empty, you might want to try using ACPI instead of APM.

I've been told that server chipsets usually do not shut off automatically even though APM or ACPI is turned on. Just so you can prepare for the worst...
 
Old 12-23-2004, 03:40 AM   #4
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for you all,
I don't know this symtom regard with APM or not.
because of in previously time,
This system can shutdown by normally.
But a couple weeks ago.
This system needs to come and turn it off.
This is Dell Server.

I've run command that get result
$apm -v
APM BIOS 1.2 (kernel driver 1.16)
AC on-line, no system battery.

Could you have the other suggestion???

regards
 
Old 12-23-2004, 03:55 AM   #5
daihard
Member
 
Registered: Jul 2003
Location: Lynnwood, WA
Distribution: Kubuntu 10.10
Posts: 912

Rep: Reputation: 32
Quote:
Originally posted by LiloAma
I've run command that get result
$apm -v
APM BIOS 1.2 (kernel driver 1.16)
AC on-line, no system battery.

Could you have the other suggestion???
Is your APM daemon running?
 
Old 12-23-2004, 03:59 AM   #6
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Hint:

Code:
root@smoker / # ps aux | grep apm
root        38  0.0  0.0     0    0 ?        S    Nov10  61:44 [kapmd]
root      8935  0.0  0.0  1444  480 pts/1    R+   04:08   0:00 grep apm
root@smoker / #
Something like that anyway.

 
Old 12-23-2004, 04:42 AM   #7
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for your help
I didn't found this deamon.
How could i run this service and make it as auto??
regards,
 
Old 12-23-2004, 05:13 AM   #8
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
again.
This is result.
$ apm -v
No APM support in kernel

Is this package need to be installed??

regards,
 
Old 12-23-2004, 05:53 AM   #9
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
I think it has to be in the kernel. I'm not sure how Redhat does their kernel. I'm a Gentoo nut so I know how to redo mine but I have never used Redhat. You may want to see if you have the kernel sources installed. May also want to seach the Redhat section. I'm sure there is a how to in there somewhere.

Sorry I can't help more than that. Maybe a Redhat user will come along and help.

Later

 
Old 12-23-2004, 06:21 AM   #10
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Hi Dalek,
Could you share that in this?
I'd like to know what did you do in Gento?

regards,
 
Old 12-23-2004, 01:10 PM   #11
daihard
Member
 
Registered: Jul 2003
Location: Lynnwood, WA
Distribution: Kubuntu 10.10
Posts: 912

Rep: Reputation: 32
Quote:
Originally posted by LiloAma
Hi Dalek,
Could you share that in this?
I'd like to know what did you do in Gento?
Red Hat shoud have the APM support built in to the kernel. You get "No APM support" from "apm -v" when the apmd daemon is not running. I believe all you have to do is enable the "apmd" daemon to start up at boot time.

You should have the command-line tool called "chkconfig." That lets you do it. First, type in (as root):

# chkconfig --list apmd

This will show whether or not the apmd daemon is on the list of services. If it comes back empty, run (again as root):

# chkconfig --add apmd

This will add the daemon as a service that can be started at boot time. Type the following to make sure it's turned on:

# chkconfig apmd on

This should enable the apmd daemon to start at boot time.

Good luck!
Dai
 
Old 12-23-2004, 07:59 PM   #12
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks you daihard,
I'll try.
Anyresult, will let you know
 
Old 12-30-2004, 03:21 AM   #13
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Dear,
I've followed as your advice above.
It doesn't work.
It's still forzen on:
$poweroff
|
|
|

Halting System
md: stopping all md devices.
Flushing ide devices: hda
Power down..

Then i've to turn power off button anyway.
Could you let me know any solution?

regards,
 
Old 12-30-2004, 03:30 AM   #14
LiloAma
LQ Newbie
 
Registered: Nov 2003
Posts: 21

Original Poster
Rep: Reputation: 15
again,
I've turned it on already.
$chkconfig --list | grep apmd
apmd 0n 1n 2n 3n 4n 5n 6n
 
Old 12-30-2004, 10:25 AM   #15
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
what happens if you use this command?

/sbin/poweroff -p
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help please... System Halting!?! MadLogic Linux - Software 2 07-21-2005 07:16 AM
System Halting while shutdown LiloAma Linux - Hardware 5 12-23-2004 01:49 PM
halting the system jogurt666 Debian 2 02-16-2004 04:59 AM
Redhat 9 System not halting properly ksgill Linux - Newbie 2 07-15-2003 09:48 PM
halting system at graphical login reepark Linux - General 3 08-13-2002 05:31 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration