LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Synaptic - font is too small (http://www.linuxquestions.org/questions/linux-software-2/synaptic-font-is-too-small-4175432024/)

pwabrahams 10-13-2012 11:00 AM

Synaptic - font is too small
 
I'm running Kubuntu 12.04.1. The font in Synaptic (both the menu bar and the data) is too small. I've set the font in Systems Settings and it works in most places, but not there. Synaptic has a Preferences section with an Application Font setting and a Terminal Font setting. But those two don't seem to have an effect either.

Other people seem to have had this problem, but I haven't found any solutions. One poster said that the Synaptic preferences would do the trick, but they don't -- at least not for me.

Where is that font setting hiding out?

replica9000 10-13-2012 11:22 AM

System settings - from KDE? If you're running KDE, which is a QT based desktop, not all settings would affect GTK applications, which Synaptic is.

Under System Settings > Application Appearance > GTK Configuration - you can control the font size for GTK apps. If you don't have that option, check that the package kde-style-qtcurve is installed. It will make your GTK apps look like KDE apps.

pwabrahams 10-13-2012 12:14 PM

GTK setting doesn't seem to work
 
Under "GTK Applications", the widget style is set to QTCurve. The fonts are set to "Use my KDE fonts in GTK+ applications", although there's no choice there; the other alternative of a specific font is greyed out.

I'm beginning to think there might be a bug here that prevents the application of KDE fonts to GTK applications, since a similar problem has shown up elsewhere. In the past, the KDE fonts did seem to be used in Synaptic and such, but I don't remember how long ago that was. I noticed that QTCurve wasn't installed, but installing it didn't make any difference.

pwabrahams 10-13-2012 01:36 PM

QTCurve is the answer
 
My confusion. I have two laptops side by side both running Kubuntu 12.04, and I was checking the wrong one. In fact, going into System Settings / Application Appearance / GTK+ settings has a place at the top to set the widget style, and that should be QTCurve. If QTCurve isn't listed, you'll need to install it (the package name is just that -- QTCurve).


All times are GMT -5. The time now is 10:18 AM.