LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-11-2010, 05:17 PM   #1
page_seven
Member
 
Registered: Jun 2010
Distribution: CRUX 3.0
Posts: 75

Rep: Reputation: 0
switching to vt kills internet connection


When I switch from X to a virtual terminal, my internet connection fails. here is lines from syslog
Code:
Sep 11 15:09:01 none dhcpcd[21830]: wlan0: carrier lost
Sep 11 15:09:01 none kernel: No probe response from AP XX:XX:XX:XX:XX:XX after 500ms, disconnecting.
Sep 11 15:09:01 none kernel: cfg80211: Calling CRDA to update world regulatory domain
Sep 11 15:09:01 none dhcpcd: wlan0: MTU restored to 1500
 
Old 09-11-2010, 05:31 PM   #2
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
The one thing about Wi-Fi is that GUI tools for configuring it don't work at the console login. As such, you have to use the command line to reconfigure it:

Code:
sudo iwconfig wlan0 essid <your network's name> key <your network's WEP or WPA key>
sudo iwconfig wlan0 commit
 
Old 09-11-2010, 06:52 PM   #3
page_seven
Member
 
Registered: Jun 2010
Distribution: CRUX 3.0
Posts: 75

Original Poster
Rep: Reputation: 0
reboot fixed it
 
Old 09-12-2010, 12:22 AM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
If you're happy with your results, mark this thread "Solved".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Have internet connection, but router doesn't 'see' me after switching to static IP Ariox Ubuntu 4 05-06-2007 03:30 PM
Something kills my DSL internet connection Iltbreg Linux - Networking 3 04-15-2007 04:08 PM
Ubuntu kills internet connection gentisle Ubuntu 2 05-12-2005 04:02 PM
Ubuntu kills internet connection gentisle Linux - Newbie 2 05-11-2005 08:25 PM
freeswan kills internet connection dmarkow Linux - Networking 0 02-27-2004 07:04 PM


All times are GMT -5. The time now is 08:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration