LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   "Switch user" menu item in KDE (http://www.linuxquestions.org/questions/linux-software-2/switch-user-menu-item-in-kde-265311/)

jimk 12-11-2004 03:08 PM

Need "Switch user" menu item in KDE
 
I just installed Fedora Core 3 and changed my default desktop to kde/kdm.

Does anybody know how to add the "switch user" menu item like Suse and Xandros have? After an hour of Googling, the best I can come up with is "Start new session," but that's not the same thing. It doesn't let me switch easily between sessions already running.

I know how to use Ctrl+Alt+Fkey, but I'm looking for a mouse-able way.

fuzzyworm 12-20-2004 05:33 AM

Sorry so long in replying!!
 
ok, assuming you're using kdm with kde3, edit /etc/kde3/Xservers, and delete the '#' at the start of at least one of the following lines to uncomment them:

Code:

:1 local@tty2 reserve /usr/X11R6/bin/X -nolisten tcp :1 vt8
:2 local@tty3 reserve /usr/X11R6/bin/X -nolisten tcp :2 vt9
:3 local@tty4 reserve /usr/X11R6/bin/X -nolisten tcp :3 vt10
:4 local@tty5 reserve /usr/X11R6/bin/X -nolisten tcp :4 vt11

This will allow kdm to open 4 more instances. To get the menu entry back, all you need to do is restart kdm with more than one slot available.

Hope this is still of use

jimk 12-21-2004 11:46 PM

Re: Sorry so long in replying!!
 
Hi fuzzyworm. I appreciate your reply.

I tried what you suggested before, but all that did was give me the "Start new session" menu entry. I'm looking for the "switch user" menu entry that you see in Suse and Xandros. While both allow you to run multiple sessions, "switch user" shows a list of current sessions and allows you to choose among all of them. "Start new session" is good for quickly logging in and out to check email or something, but it doesn't work for going back and forth among concurrent sessions. I personally don't mind using Ctrl+Alt+F7/F8 etc., but other members of my family find it too confusing and want to be able to mouse their way to their own session.

I hope I'm explaining the difference and that you understand why I'm being so picky.

Or is there something else that I'm missing or doing wrong?

fuzzyworm 01-02-2005 03:57 PM

Sorry, that's a thing peculiar to the distro. It does pretty much the same thing, if you click 'lock screen' it gives you the option to start a new session, whilst locking your current screen.

jimk 01-02-2005 06:28 PM

I'm not interested in locking my session. I'm interested in a way to have three people logged in and have an easy way to switch to their own session without having to remember who's F7 and who's F8 etc. The KDE manual says the "switch user" menu's supposed to be in there. "Switch user" gives you a list of currently logged-on users so you can just click on your own name.

I guess I'll just have to go back to Suse. I switched to Fedora because I wanted newer versions of packages and the security of SELinux, but having tried it, I think I like Suse better.

Thanks for trying to help me, Fuzzy.

kilgor 01-11-2005 09:25 AM

same thing, FC2
 
I'm trying to accomplish about the same thing as jimk.

Running FC2 (don't feel the need to upgrade to FC3 right now).
Linux 339-linux 2.6.8-1.521.stk16 #1 Fri Sep 3 08:45:37 CDT 2004 i686 athlon i386 GNU/Linux
(Although the kernel with bigger stk is installed, the NVidia drivers are not ATM.)

At my parents' place I've got Suse 9.2 with KDE running and the 'Switch User' feature was a really nice thing. I'd would really need it now, so my stuff would be separate from my roommate's. Living at a dorm.

I don't really need the Switch User button itself as much as I need two separate KDE screens. Ctrl+Alt+F7/F8 is just fine and even better. They may as well both start automagically when booting to linux, autologin would be great I guess. ATM autologin is enabled for the only screen i'm using.

/etc/kde/kdm/Xservers is a sym link which points to ../../X11/xdm/Xservers

So the revelant contents of the Xservers file was:

Code:

:0 local /usr/X11R6/bin/X
Which i changed to:

Code:

:0 local /usr/X11R6/bin/X
:1 local@tty2 reserve /usr/X11R6/bin/X -nolisten tcp :1 vt8
:2 local@tty3 reserve /usr/X11R6/bin/X -nolisten tcp :2 vt9

Restarted X and discovered, that it did really nothing. So I changed the first line too.

Code:

:0 local@tty1 reserve /usr/X11R6/bin/X -nolisten tcp :1 vt7
:1 local@tty2 reserve /usr/X11R6/bin/X -nolisten tcp :1 vt8
:2 local@tty3 reserve /usr/X11R6/bin/X -nolisten tcp :2 vt9

And no effect what so ever.

Nothing was added to the startmenu. There's the "Logout..." button, which asks if I really want to log out to the main login screen or Cancel the operation. And there's the Lock Screen button, which locks the screen right away without asking anything.

Ctrl+Alt+F1..6 gives me the login to the usual commandline. F7 is the screen i'm using. F8..12 give blank black screens with an underscore char at the top left corner. Can't do anything there except for switching between screens and probably other X shortcuts.


So the big question is, how do I get two simultaneous kde screens running under FC2?


Thanks in advance.

edit:

Got it working thank's to this page.

So Xservers ended up looking like this:
Code:

:0 local@tty1 /usr/X11R6/bin/X -nolisten tcp vt7
:1 local@tty2 reserve /usr/X11R6/bin/X -nolisten tcp :1 vt8
:2 local@tty3 reserve /usr/X11R6/bin/X -nolisten tcp :2 vt9

And I had to switch from gdm (FC2 default) to kdm, which supports the feature. The display manager is set by /etc/X11/prefdm, so to make it choose kdm instead of gdm, I had to add
Code:

DISPLAYMANAGER="KDE"
to /etc/sysconfig/desktop. It ended up looking like this:
Code:

DESKTOP="KDE"
DISPLAYMANAGER="KDE"

Hope it'll help someone.

fuzzyworm 01-15-2005 05:44 AM

Yeah, it's a feature of KDM, or at least, GDM supports it, but the nice menu entry would have been added to the GNOME menu, I suspect. I'm glad you got it working.

I read somewhere, I can't remember where, that the switch user thing can be set up only by patching KDM, something which evidently Xandros and SuSE, or whatever the other one was, have done. I'll have a look around, I don't like the computers to beat me :( !!!

edit:
Ok, I've found the SuSE patch to do it:

kdm-switch-users.diff


All times are GMT -5. The time now is 12:55 AM.