LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-21-2003, 05:13 PM   #1
theguy311
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
Exclamation Swat Samba whatever!


Hello,

In so far I have been unable to get Samba or even Swat to work on my linux machine. I have downloaded and reinstalled numerous times samba and swat also tried webadmin.

When i try to connect to
http://10.0.0.11:901 says document refused

also when i type:

# rpm -qa | grep samba

i don't get swat like the Red Hat Bible gets...
they get:
samba-*
samba-swat
samba-common
samba-client

I get all but swat.

I have read every post on this board about swat and samba and have followed instructions exactly... also went to samba.org download new .tar.gz files for them and still exact same thing.



Kind of unlreated but could help, how do I open ports to allow outside machines to access them?

- Guy

Last edited by theguy311; 01-21-2003 at 05:40 PM.
 
Old 01-21-2003, 05:39 PM   #2
theguy311
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Here is my smb.conf

If someone could help me just get samba running, that would be the best to learn this stuff better
-----------------------------------------
# This is /usr/local/samba/lib/smb.conf

[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = MSHOME

# server string is the equivalent of the NT Description field
server string = Linux Box

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
encrypt passwords = yes
smb passwd file = /usr/local/samba/bin/smbpasswd

[pub]
path = /home/public
browseable = yes
guest ok = yes
read only = no

[homes]
comment = Home Directories
browseable = no
writable = yes
------------------------------------------------------------
 
Old 01-21-2003, 07:35 PM   #3
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
what version of RH r u using? if you are using the 7.x or 8.x series, they all have the swat utility in the CDs. Once you have installed it, u need to enable it using this command:

/sbin/chkconfg swat on

And then, locally, point your browser to http://127.0.0.1:901/. Be sure that if u have fwall rulesets, connection to 901 is open (or just disable the fwall for a few minutes until you have configured samba).

Most ports are controlled by daemons or services (ie port 21 is controlled by ftp daemons, port 22 by sshd). enabling these ports means to allow the daemons to accept connections ie by starting them or by opening them up (like what you need to do for swat).

FYI, the Red hat shipped samba places its smb.conf file in /etc/samba/.
 
Old 01-21-2003, 07:41 PM   #4
rohang
Member
 
Registered: Aug 2002
Location: Sydney, Australia
Distribution: Redhat, Open BSD, SuSe, Debian, CentOS
Posts: 177

Rep: Reputation: 30
You'll find that swat (by default) will only listen on 127.0.0.1:901.

Give that a try rather than whatever address you assign to your eth0 interface.

You'll have to again (by default) login with username root and your root password.

 
Old 01-24-2003, 12:28 PM   #5
theguy311
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Hello,

When i go to /sbin/chkconfg swat on it says no such file or directory. We are running on Red Hat 8.0.

But I know swat is on the computer because I reinstalled it.

- Guy
 
Old 01-24-2003, 12:52 PM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Try /sbin/chkconfig swat on



Cool
 
Old 01-24-2003, 12:58 PM   #7
theguy311
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Thank you MasterC swat turned on...
but when i try to connect to it either through the one you guys said or 10.0.0.11... still says connection refused.

This is driving me nuts.
 
Old 01-24-2003, 01:00 PM   #8
theguy311
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Also firewall is inactive.
 
Old 01-25-2003, 01:42 PM   #9
scape
LQ Newbie
 
Registered: Jan 2003
Location: Chico, Ca
Distribution: mandrake 9.0
Posts: 19

Rep: Reputation: 0
I found a great SAMBA help site.. Real quick run through and I got SAMBA working in 5 minutes..

http://www.linuxorbit.com/howto/sambahowto.php3
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Samba/SWAT driesel Linux - Newbie 3 02-13-2005 09:33 AM
Samba + SWAT mooler Linux - Networking 5 11-13-2003 09:46 AM
Samba and swat james.farrow Linux - Networking 7 04-04-2003 11:27 AM
SAMBa and SWAT Snake007uk Linux - General 8 05-16-2002 07:30 PM
samba swat has me chens_83 Linux - General 2 03-22-2002 06:31 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration