LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-27-2010, 04:09 AM   #1
Beekman
Member
 
Registered: Mar 2010
Location: Kampen, The Netherlands
Distribution: Ubuntu 11.04
Posts: 32

Rep: Reputation: 0
SVN does not work in Eclipse after Ubuntu upgrade


I recently upgraded my Linux Ubuntu from 10.04 to 11.04, but after the upgrade my Eclipse lost it's plugins.
So I re-installed subclipse (using http://subclipse.tigris.org/update_1.4.x), but it does not work;
There is a "<SVN Repository Exploring>-perspective>" but it does not contain the right Views, and I can't add them manually, beacause there is no 'SVN'-category.

I tried to reinstall Eclipse, but when I remove and re-add it using Ubuntu Software Center all features and plug-ins are exactly the way they were... So I still can't use SVN.

Can anyone help me fix my problem, or tell me how I can really delete Eclipse and reinstall it from scratch?
 
Old 12-27-2010, 04:38 AM   #2
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Rep: Reputation: 33
Try eclipse with a new and clean workspace, also try remove all the old plugins. The reinstall subclipse. The plugins don't show up does not mean they were lost, they may be still there and corrupted.
 
Old 12-27-2010, 05:16 AM   #3
Beekman
Member
 
Registered: Mar 2010
Location: Kampen, The Netherlands
Distribution: Ubuntu 11.04
Posts: 32

Original Poster
Rep: Reputation: 0
Still no luck...
I removed all SVN-related plugins, re-installed Eclipse and re-installed the plugins.

It just lools like it's not installed (there is no perspective, no views, no preferences, nothing), but I'm not able to install subclipse or svnkit because it's already installed...

Edit;
I installed Eclipse 3.6 from the Eclipse update site and now everything works without problems...

Last edited by Beekman; 12-27-2010 at 06:01 AM.
 
  


Reply

Tags
eclipse, svn, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Webcam doesn't work after upgrade to Ubuntu 8.10 FewClues Linux - Hardware 1 04-27-2009 07:38 PM
Which is Best - SVN or CVS for Eclipse? your_shadow03 Linux - Newbie 1 03-09-2009 07:33 AM
Error during SVN Repo Access through EClipse? your_shadow03 Linux - Server 1 08-27-2008 12:20 AM
Eclipse, SVN and JavaHL on Fedora Core 6 marie@dk Linux - Software 1 07-17-2007 12:02 AM
Eclipse crashes when using SVN rejeep Linux - Software 1 07-15-2007 12:54 PM


All times are GMT -5. The time now is 02:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration