LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-08-2005, 11:25 AM   #1
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Rep: Reputation: 15
Suse 9.2 Nvidia Geforce 4 420 Go Black Bar


Hi all! I have a problem with the infamouse Toshiba Black Bar issue!

I can get Mandrake 10.1 running with everything, but i have suse 9.2 on my desktop and would like to standardize things, plus I like suse better...anyhow...I compiled the drivers for linux off the nvidia website with the usual procedure

modprobe agpgart
sh installnvidiadriverhere -q

and then did sax2 0=nvidia and set that up

ok, then i get the black bar..normally with linux I go into XF86Config and do

Option "IgnoreEDID"

and voila its fixed...at least for Mandrake it is...

However with Suse what happens is this ugly thing where the scren scruntches up and then displays a duplicate image with a colored garbled bar running through the middle...so still havent fixed that...
can anyone rectify this for me?

Do I need to edit anything else? Am I missing something? Want to get rid of mandrake and stay with Suse!!
 
Old 04-08-2005, 12:38 PM   #2
Lier
Member
 
Registered: Jan 2005
Location: Argentina
Distribution: SUSE 9.0, 9.2, 10.0, Slackware 10.2 and slamd64
Posts: 135

Rep: Reputation: 15
To install on Suse, follow this steps:

1- init 3 (as root)
2- rmmod nvidia (i don't think this step it's necessary, if it gives you an error continue with the next step)
3- cd /usr/src/linux
4- make cloneconfig
5- make prepare-all
6- sh NVIDIA-Linux-x86-1.0-7167-pkg1.run -q --kernel-source-path=/usr/src/linux
7- modprobe nvidia
8- sax2 -m 0=nvidia

Be shure to have the kernell source installed, if you haven't you can fint it on the dvd from suse.
You have to log as root to do everything.

Good luck-
 
Old 04-08-2005, 12:53 PM   #3
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Er, ive done that already...the make clone stuff isnt necessary..its the IgnoreEDID parts and such...something is up with Suse versus the other distros out there....
Why isnt IgnoreEDID working when it does on other distros with XF86?
 
Old 04-08-2005, 01:03 PM   #4
Lier
Member
 
Registered: Jan 2005
Location: Argentina
Distribution: SUSE 9.0, 9.2, 10.0, Slackware 10.2 and slamd64
Posts: 135

Rep: Reputation: 15
If you want to install it on suse you have to do what i've told you before. I don't know why are you trying to use "IgnoreEDID" to install it, if you read the HOWTO from nvidia web-page for suse users you'll get noticed that you don't have to use "IgnoreEDID".
 
Old 04-08-2005, 01:09 PM   #5
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
That I can see, however having a Toshiba laptop with the black bar issue, the normal procedure is not always the case...

what are you using for a machine?
Are you using one of the toshiba's, dells,or the other few mfg's out there wth the black bar issue from the bad video bios?

And if so I can see that it would help, but I am hoping that someone who deals with the black bar issue on the side of the screen can give some insight.
 
Old 04-08-2005, 02:25 PM   #6
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Bump
 
Old 04-08-2005, 07:27 PM   #7
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Installing Suse again right now..will try your method, hopefully it will work i'd like to be able to play games here and ther eon my laptop

Not to mention DVD hardware playback is better with nvidia enabled.

In the mean time anyone else have anything they could add? I do appreciate all the feedback.
 
Old 04-08-2005, 08:18 PM   #8
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Ok i did exactly what you said, now I still get the big black bar running veritcally down the side of the screen.
 
Old 04-08-2005, 08:20 PM   #9
Jediman
LQ Newbie
 
Registered: May 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Never mind, what i did was this:

"Ignore EDID" "1" in the xorg.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia Geforce 4 420 Go On Presario 3410 US roxmenon Linux - Hardware 1 01-20-2006 10:42 PM
Help With NVidia Geforce 4 MX 420 TwiztedTom Linux - Hardware 4 05-08-2005 12:05 AM
Black bar on right side of screen after installing NVidia 5336 drivers CarletonKnight Linux - Laptop and Netbook 5 07-06-2004 08:06 PM
Toshiba 5100 & Nvidia - black bar on right side of my screen? rnmartinez Linux - Laptop and Netbook 0 06-10-2004 08:26 PM
GLX/Xfree86/DRI/nvidia geforce 4 mx 420 problem asalford Linux - Hardware 3 04-01-2004 02:28 PM


All times are GMT -5. The time now is 10:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration