LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-04-2004, 12:26 PM   #1
jdeisenberg
LQ Newbie
 
Registered: Jun 2004
Location: San Jose, CA
Distribution: SuSE
Posts: 1

Rep: Reputation: 0
SuSE 9.1 eliminating -nolisten tcp


I would like to be able to do xhost +localhost so that I can run X-based programs after doing an su to root. I have set DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" in /etc/sysconfig/displaymanager, but the X server insists upon starting up with -nolisten tcp, as shown by this line from ps aux

root 3251 9.9 5.7 42172 21188 ? S 09:38 5:00 /usr/X11R6/bin/X -nolisten tcp -br vt7 -auth /var/lib/xdm/authdir/authfiles/A:0-qJklEc

/etc/sysconfig/displaymanager recommends instead using SSH with port forwarding, but I'm not sure how to do that. (I cannot do "ssh 127.0.0.1" as root; I get ssh: connect to host 127.0.0.1 port 22: Connection refused)

Any solution would be greatly appreciated.
 
Old 06-04-2004, 04:38 PM   #2
afrodocter
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 110

Rep: Reputation: 15
as far as the -nolisten-tcp option, i have mine enabled in the file " /etc/X11R6/bin/startx "
for ssh you must enable sshd, try " service sshd start"
the config for that is in /etc/ssh/sshd_config , i think.
also make sure that your firewall opens port 22.

hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
--nolisten tcp glock19 Linux - General 11 02-05-2013 03:45 PM
-nolisten tcp for X ferreter Fedora 3 07-19-2004 02:38 PM
X server - how to disable the -nolisten tcp startx default? lugoteehalt Debian 3 05-04-2004 07:12 AM
startx -nolisten tcp shanenin Slackware 2 11-12-2003 04:00 PM
-nolisten tcp Xgates Linux - Security 4 01-23-2003 04:48 AM


All times are GMT -5. The time now is 11:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration