LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   SuSE 9.1 eliminating -nolisten tcp (http://www.linuxquestions.org/questions/linux-software-2/suse-9-1-eliminating-nolisten-tcp-189698/)

jdeisenberg 06-04-2004 12:26 PM

SuSE 9.1 eliminating -nolisten tcp
 
I would like to be able to do xhost +localhost so that I can run X-based programs after doing an su to root. I have set DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" in /etc/sysconfig/displaymanager, but the X server insists upon starting up with -nolisten tcp, as shown by this line from ps aux

root 3251 9.9 5.7 42172 21188 ? S 09:38 5:00 /usr/X11R6/bin/X -nolisten tcp -br vt7 -auth /var/lib/xdm/authdir/authfiles/A:0-qJklEc

/etc/sysconfig/displaymanager recommends instead using SSH with port forwarding, but I'm not sure how to do that. (I cannot do "ssh 127.0.0.1" as root; I get ssh: connect to host 127.0.0.1 port 22: Connection refused)

Any solution would be greatly appreciated.

afrodocter 06-04-2004 04:38 PM

as far as the -nolisten-tcp option, i have mine enabled in the file " /etc/X11R6/bin/startx "
for ssh you must enable sshd, try " service sshd start"
the config for that is in /etc/ssh/sshd_config , i think.
also make sure that your firewall opens port 22.

hope this helps


All times are GMT -5. The time now is 11:10 AM.