LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-08-2003, 11:14 PM   #1
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Rep: Reputation: 15
Question SuSe 8.2 Boot and Shutdown Screens


Hi,

I'm a newbie to Linux and I just installed Suse 8.2 on my computer. I have seen Suse installations that, when Linux is Booting up, there is a splash screen with a progress bar that says "Booting the System... Press F2 for Verbose Mode" and when it is shutting down, it has another splash screen and says "Shutting Down The System... Press F2 for Verbose Mode" and it also has a progress bar. My installation does not do that. It just shows a bunch of text while it is booting or shutting down. I would like to have the splash screens instead. How can I get the splash screens to work? Thanks.

BTW please explain everything thoroughly as I do not know very much about Linux yet.
 
Old 10-09-2003, 12:55 AM   #2
SuSE_Surfer
Member
 
Registered: Oct 2003
Location: Wiesbaden, Germany
Distribution: Dual Boot RedHat 9 / XP
Posts: 34

Rep: Reputation: 15
Bootup screen

Are you using a boot loader first off?

You should have a screen that comes up at boot that asks you to boot Linux, Windows (if your dual boot), or Linux Safe Mode.

At the bottom of that window, you will see a selection to press F2 for Native or Verbose mode.

Native mode will give you the splash screen with the progress bar.

Verbose mode will give you all that "jumble-lumble" it displays during boot up.

Hope this helps.

SuSE_Surfer
 
Old 10-09-2003, 01:22 AM   #3
krussell
Member
 
Registered: Jul 2003
Location: dhaka
Distribution: Slackware 11 (fixed), MEPIS
Posts: 241

Rep: Reputation: 30
i wish i were you, i am trying to disable the boot splash and go into verbose mode. how did u do that?
 
Old 10-09-2003, 06:55 AM   #4
SuSE_Surfer
Member
 
Registered: Oct 2003
Location: Wiesbaden, Germany
Distribution: Dual Boot RedHat 9 / XP
Posts: 34

Rep: Reputation: 15
Boot option Verbose/Native

When booting, in reference to GRUB, you should have an option to select Native/Verbose mode.

When installing with the Boot CD, you know that screen that you get where it asks for either Installation, or to Boot from hard disk, etc?

You are going to be looking for that same graphical screen.

When that appears, hit F2, and you will have the option to select Native/Verbose/and one other option which I can not think of off the top of my head. Check it out...let me know if it helps.

SuSE_Surfer
 
Old 10-09-2003, 08:29 AM   #5
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
http://sdb.suse.de/sdb/en/html/fhassel_bootmenu.html
 
Old 10-09-2003, 10:43 AM   #6
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
Ok, Thanks. I will Try This and get back to you. Oh, and I am using Grub to dual boot.

Last edited by Louie55; 10-09-2003 at 10:44 AM.
 
Old 10-11-2003, 11:48 PM   #7
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
Ok, I have tried EVERYTHING and the splash screens still don't work! In the menu.lst file in the /boot/grub directory, I have the splash=silent showopts. I have chosen native and silent as the boot choice on the Grub F2 menu and still no splash screens. I have all of the bootsplash packages installed.

Just a little more info:

Maybe it has something to do with my screen? When I try to configure my monitor in Yast2, it says it can't configure my monitor because my brand of monitor is not in it's config files. So I have to configure it as a default VESA 800X600 screen. Everytime I start Linux, it shows a little message that says "Your screen resolution has changed".

Also, at the college I go to, they have SuSE installed and when you boot in Verbose mode, it has a blue screen with the SuSE logo in the top right corner and has a blue border abound it with a nice "pretty" screen for the verbose text. Well, my computer doesn't do that. When it is displaying the text during boot/shutdown, it is just plain white text on an all black screen. No graphics at all.

Another thing I noticed is that when the computer starts shutting down or starting up, it says "Skipped Services in Runlevel 5" and then on the right side of the screen it says "Splash". I don't know if this has anything to do with my problem or not?

Any More Ideas?

Thanks
 
Old 10-12-2003, 04:20 AM   #8
dagza
LQ Newbie
 
Registered: Jul 2003
Location: NE, England
Distribution: Suse 8.2
Posts: 5

Rep: Reputation: 0
Also having similar problems. Whichever F2 option I choose I just get white text on a black backgrond. I have just reently reinstalled grub.

Interetting about monitor / graphics card. Every time i get into SuSE my geometry is slightly to the left. I can't change this is yast as it tries to install sax2 (i think) and juset hangs. I can run sax2 directly and configure it to the right a little bit - hit test - the blue screen is too far to the right now so I have to move it back and it works (until the next boot)!

Hmmm
 
Old 10-12-2003, 05:29 AM   #9
dagza
LQ Newbie
 
Registered: Jul 2003
Location: NE, England
Distribution: Suse 8.2
Posts: 5

Rep: Reputation: 0
Fixed !!!!

simply typing mkinitrd into a command window did the trick. (Also seem to sort out the video issue but I dunno if this is just a coincidence). Right at the bottom of the URL posted by rshaw

http://sdb.suse.de/sdb/en/html/fhassel_bootmenu.html
 
Old 10-12-2003, 12:27 PM   #10
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
Well, the mkinitrd command didn't work either. I even did the mkinitrd -s 800x600 command and it did it's thing and said "splash picture=800x600" so I thought I had it! But, restarted the computer and same old black screen. I have tried starting in Native, Silent, and Verbose modes but it is always the same black screen with white letters.

It still says my screen configuration has changed when I start KDE.

Just for more info, I will give you my partition layout for my computer:

1st Hard Drive
1st Partition: FAT32-Windows 98
2nd Partition: FAT32-Windows 98 Programs
3rd Partition: FAT32-Data
4th Partition: NTFS-Windows 2000
5th Partition: Linux Swap
6th Partition: Linux

2nd Hard Drive
1st Partition: NTFS-Windows XP Pro

System is Quadruple booted using GRUB and Windows boot.ini bootloaders.

Probably doesn't mean anything but you can never give too much information.
 
Old 10-13-2003, 08:25 PM   #11
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
BUMP

Still Not Working
 
Old 10-13-2003, 08:57 PM   #12
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
can you post your boot/grub/menu.lst
 
Old 10-13-2003, 09:06 PM   #13
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
or at a root term type: echo 0x0f01 >/proc/splash then type: SuSEconfig
 
Old 10-14-2003, 12:51 AM   #14
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
Here is my menu.lst:

color white/blue black/light-gray
default 0
gfxmenu (hd0,8)/boot/message
timeout 8

title windows
root (hd0,0)
chainloader +1

title linux
kernel (hd0,8)/boot/vmlinuz root=/dev/hda9 hdc=ide-scsi hdclun=0 splash=silent showopts
initrd (hd0,8)/boot/initrd

title floppy
root (fd0)
chainloader +1

title failsafe
kernel (hd0,8)/boot/vmlinuz.shipped root=/dev/hda9 showopts ide=nodma apm=off acpi=off vga=771 nosmp noapic maxcpus=0 3
"menu.lst" [readonly] 23L, 568C 22,98 50%
 
Old 10-14-2003, 12:32 PM   #15
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Original Poster
Rep: Reputation: 15
BUMP

Any Ideas after seeing the menu.lst? I still think it might have something to do with SuSE not being able to recognize my screen correctly. I have a Komodo monitor and it is not in the list of supported screen manufacturers. Right now I have it working on a default VESA 800X600 driver. Everytime I run SaX2, it says "Monitor not found. Please configure Manually" or something to that nature. Any more ideas are appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.3 boot and shutdown help!!! huilin SUSE / openSUSE 10 07-29-2005 05:58 AM
Suse 9.3 Splash Screens brainee28 SUSE / openSUSE 2 07-22-2005 06:37 PM
LILO boot screens for Slack pirgos_madden Slackware 2 11-05-2004 02:39 AM
No screens found, SuSE 8.1 ChineseElite Linux - Software 2 08-30-2003 12:48 AM
boot screens in Red Hat 8.0 leifdawg Linux - Distributions 2 12-14-2002 06:18 PM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration