LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-28-2006, 02:16 PM   #1
Doolspin
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Slackware 9.1/10/10.1 RedHat circa 2000, Knoppix, OpenSuse 10.0/10.1
Posts: 122

Rep: Reputation: 15
Suse 10.1 and an Atheros card


So, I've been having a problem with my Atheros wireless card. It acts very dodgy, offen dropping the conncetion, or not connectioning at all. I have found this in my dmesg

ath_hal: module not supported by Novell, setting U taint flag.
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.17.2 < http://0.9.17.2> (AR5210, AR5211, AR5212, RF5111,
RF5112, RF2413, RF5413)
wlan: module not supported by Novell, setting U taint flag.
wlan: 0.8.4.2 < http://0.8.4.2> (0.9.1)
ath_rate_sample: module not supported by Novell, setting U taint flag.
ath_rate_sample: 1.2 (0.9.1)
ath_pci: module not supported by Novell, setting U taint flag.
ath_pci: 0.9.4.5 <http://0.9.4.5> (0.9.1)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 82
PCI: Setting latency timer of device 0000:03:00.0 to 64
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.3 phy 6.1 radio 10.2
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wlan_scan_sta: module not supported by Novell, setting U taint flag.
wifi0: Atheros 5212: mem=0xedf00000, irq=82

Anyone have any ideas?
 
Old 08-28-2006, 04:27 PM   #2
digital8doug
Member
 
Registered: Aug 2006
Location: Near Binghamton, NY-the recent FLOOD zone
Distribution: Sabayon 351, Mepis8, oSuse11.3, Kubuntu8.1, Fed10, Slack12.1 #426299 RLU
Posts: 145
Blog Entries: 1

Rep: Reputation: 15
Exclamation U install Atheros WiFi drivers? 10.1 dropped some WiFI

I thought release notes indicated 10.1 dropped coverages for some WiFi & was lead to believe AR was not on Suse 10.1 Maybe OK w/ 10.0??
Did U locate & update drivers for Atheros? Which card #? Where?
I have AR5006XS but been told recently, no Suse 10.1 drivers yet .
 
Old 08-28-2006, 04:34 PM   #3
Doolspin
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Slackware 9.1/10/10.1 RedHat circa 2000, Knoppix, OpenSuse 10.0/10.1
Posts: 122

Original Poster
Rep: Reputation: 15
Yes, they did drop the drivers. But the released a package with them in it. I have the new madwifi drivers. The card in an AR5212
 
Old 10-24-2006, 08:39 PM   #4
Saulo
LQ Newbie
 
Registered: Jun 2003
Location: Mexico
Distribution: XUbuntu Edgy
Posts: 23

Rep: Reputation: 15
My atheros makes a noise

Doolspin, I have an atheros card and when I disable the NetworkManager the laptop (an acer 3620) starts making an annoying noise, very sharp, that only stops when I enable again the NetworkManager.
If instead of NetworkManager I use ifup, the noise is present all the time until I execute the ifup command.
I am not sure is the atheros that makes the noise but it seems like it.
Can you help me or have any ideas?
 
Old 10-31-2006, 05:13 PM   #5
danxx
LQ Newbie
 
Registered: Mar 2005
Location: San Diego, California
Distribution: SuSE
Posts: 5

Rep: Reputation: 0
Configuring Atheros Wireless with SUSE 10.1 and MadWifi

I had a problem with SUSE 10.1 not recognizing my Atheros AR5212 802.11abg, which worked in SUSE 9.3 After much research, here's what I found. The Madwifi drivers, which support Atheros-based wifi cards were dropped from SUSE 10.1. Fortunately, you can download the packages madwifi and madwifi-kmp-default (or madwifi-kmp-* for a non default kernel) from http://www.madwifi.org/suse/
You then reboot and type
modprobe aes; modprobe wlan_ccmp; modprobe ath_pci
and verify with lsmod and ifconfig ath0
Configure with yast2 under "Network Devices-->Network Card" (don't forget to add the newly-recognized card.

More details are available at my write-ups at
http://susewiki.org/index.php?title=...Wireless_cards
and http://thinkwiki.org/wiki/Madwifi

Good luck.

Last edited by danxx; 10-31-2006 at 05:22 PM.
 
Old 11-12-2006, 05:30 PM   #6
stuart-macd
LQ Newbie
 
Registered: Nov 2006
Distribution: Suse
Posts: 1

Rep: Reputation: 0
Wireless Bliss

Thanks Danxx

I followed the instructions on your post and two links and my IBM/Lenovo ThinkPad R60e with SUSE 10.1 started doing its duty wireless wise right away.
Very nice - I only wish I had found your link earlier - had to trawl sooo much dross to find this little gem!
Cheers

Stuart
 
Old 01-19-2007, 11:24 AM   #7
Saulo
LQ Newbie
 
Registered: Jun 2003
Location: Mexico
Distribution: XUbuntu Edgy
Posts: 23

Rep: Reputation: 15
Talking About the noise of my previous post

In my previous post I pointed out that my atheros made a noise when disabled and also I noted later that little other noises were present at all times.
Just yesterday, I removed and installed again (phisically) the atheros several times. The cables from the antenna were lying on the card, over its chipset, so I kept them that way. The noises contined.
Nevertheless in one of those times, pissed off already, I left the cables lying below the card, "away" from the chipset, and that solved the problem.
Seems like the signal from the antennas were a source of severe interference [if I should say so] to the chipset.
 
Old 02-02-2007, 11:25 AM   #8
Saulo
LQ Newbie
 
Registered: Jun 2003
Location: Mexico
Distribution: XUbuntu Edgy
Posts: 23

Rep: Reputation: 15
Exclamation Sorry, noises still there, my mistake

It was just a false alarm... had nothing to do with the antennas. Noises still there though I discovered the noises begin when a usb device is plugged and the noise get even worse when disabled the atheros card... Piezzoelectric noises?? I hope.
 
  


Reply

Tags
atheros, suse, wifi, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless card Atheros matt3333 Slackware 1 07-03-2006 07:47 PM
Atheros Based Card phoenix99 Linux - Hardware 1 12-02-2005 02:14 PM
Atheros card in Gentoo linux.llama Linux - Wireless Networking 3 10-12-2005 03:52 PM
Atheros WiFi Card RySk8er30 Mandriva 4 09-04-2005 01:07 AM
help i cant get my Atheros card to freaking work! asilentmurmur Linux - Hardware 1 03-06-2005 10:37 PM


All times are GMT -5. The time now is 02:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration