LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-01-2004, 01:29 PM   #1
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
Superkaramba & Python


Hi,
I´m not using karamba often but I like the liquid weather theme and want to try it. However I doesn expected that it can be sooo difficult. I have superkaramba from before and tried to run the theme but it shows only a fully transparent rectangle which is invisible because of the transparency. From the console messages I realized that I need python for this to work. I wasn´t very pleased from the size of it but I ignored the space loss and installed it. But what? Nothing changed, nothing worked, no useful messages - it only says something is wrong with import site and $PYTHONHOME, but why should I know what is ¨import site¨ and how to set the $PYTHONHOME variable???

The message from the console is :

Code:
´import site´ failed; use -v for traceback
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
I don´t know what this means but please if somebody knows how to solve the problem, help me ! Thank you in advance.
 
Old 11-01-2004, 08:50 PM   #2
Veteq
Member
 
Registered: Feb 2004
Posts: 155

Rep: Reputation: 30
I am having the same problem, even after adding

Code:
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/lib/python2.2/:/usr/local/lib/python2.2/site-packages/gtk-2.0"
export LD_LIBRARY_PATH
to my .bashrc file as suggested in another thread.....

Mandrake 10

anyone.....?
 
Old 11-02-2004, 02:59 PM   #3
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
Nobody uses Karamba? Nobody else had the same problem? No answers... ? Why?
 
Old 11-08-2004, 07:47 PM   #4
FireHawk321
LQ Newbie
 
Registered: Nov 2004
Location: Ontairo
Posts: 8

Rep: Reputation: 0
Lightbulb

I am having the exact problem as both of you. All I was able to find was another form... But it's in german... I think.
http://www.linuxforen.de/forums/showthread.php?t=158514

*EDIT*
I kept on searching the LQ forms and came accross this:
Another Form
I am eager to try installing Qt because currently, I am not running it and my 10.1 Community CD's do not come with it.

Last edited by FireHawk321; 11-08-2004 at 08:11 PM.
 
Old 11-08-2004, 08:35 PM   #5
Veteq
Member
 
Registered: Feb 2004
Posts: 155

Rep: Reputation: 30
unfortunatly, this is the type of problem that keeps more people from switching from windows to linux. If this was a windows question, there would have been 20 replies to the problem by now . With linux, in most cases, you do get an answer but ever so often, you run into a problem that no one knows the answer to.... still will not go back to windows....

Veteq
 
Old 11-09-2004, 06:20 PM   #6
FireHawk321
LQ Newbie
 
Registered: Nov 2004
Location: Ontairo
Posts: 8

Rep: Reputation: 0
Exclamation Mandrake 10/10.1 users

I just found this RMP and it seems to half work for me. It now does not give me those weird messages on start up and runns most of the .py scripts (I made a test script that returns a simple print to the command line and it WORKED!). This is the source code from SuperKaramba 0.35 that was converted to an RPM for Mandrake 10 and Mandrake 10.1.

0.35 RPM
 
Old 11-10-2004, 01:23 PM   #7
p0z3r
Member
 
Registered: Apr 2004
Posts: 88

Rep: Reputation: 15
When you compiled it didn't detect your python libraries correctly. Superkaramba can run just .theme file by themselves without python, which is why it still compiled it for you instead of failing. What you will have to do is install your python-devel libraries for your distro and rerun ./configure --prefix=/usr && make && make install.

Here's our FAQ for more answers:
http://superkaramba.com/faq.html

And our forum on sourceforge which has most of these problems covered already:
https://sourceforge.net/forum/forum.php?forum_id=67470

cheers,
-Ryan
 
Old 11-24-2004, 03:57 PM   #8
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
I solved my problem ! I was using an old version of superkaramba and it doesn't worked with the newest python package. I updated both superkaramba and the theme to most recent versions and now works excellent. Thank you for your replies !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Python+Superkaramba onelung02 Linux - Software 5 05-01-2005 02:57 PM
superkaramba and python whitehole Linux - Software 6 02-17-2005 09:18 AM
Superkaramba Python Problems mattdev121 Linux - Software 2 01-21-2005 05:16 PM
superkaramba python error true_atlantis Linux - Software 0 12-25-2003 01:31 AM
python problems with superkaramba Tyir Linux - Software 1 11-30-2003 11:42 AM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration