LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-28-2007, 10:30 AM   #1
quincy_the_penquin
Member
 
Registered: Jun 2006
Distribution: Xubuntu
Posts: 40

Rep: Reputation: 15
Exclamation sudo stopped working: "must be setuid root"


I type in "sudo whatever" and it says in the terminal "sudo: must be setuid root". This just started today, and I can't do anything under sudo or gksudo. Help!
 
Old 04-28-2007, 10:40 AM   #2
Mizzou_Engineer
LQ Newbie
 
Registered: Jan 2006
Location: Missouri
Distribution: Gentoo 2007.0 x86 & amd64
Posts: 25

Rep: Reputation: 15
The actual "sudo" command has to be setuid root. If you type in "ls -l /usr/bin/sudo" you should see:

----s --x --s 1 root root <size> <date> /usr/bin/sudo

The "----s" means that it's setuid root. Yours probably is missing the s. You can reset sudo to setuid root by executing the following commands:

su - (logs you in as root)
chmod +s root /usr/bin/sudo (sets UID root)
exit (logs you out)

Then it should work.
 
Old 04-28-2007, 11:09 AM   #3
quincy_the_penquin
Member
 
Registered: Jun 2006
Distribution: Xubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
oops.

My bad. It turns out that I, in a moment of sheer insanity, chowned /usr/bin and everything in it so I could fiddle around with the executables in it. Thanks for the help, though.
 
Old 04-29-2007, 10:13 PM   #4
natv
Member
 
Registered: Mar 2006
Posts: 59

Rep: Reputation: 15
Hi guys,

I'm having a similar problem. I checked through the forum here and Google, and the only advice I found was to make sure the command I'm trying to run is SUID root, and that it's not on a partition mounted with the nosuid option.

I'm running on a VPS if that helps (/etc/fstab doesn't show me anything, but I don't think it would be mounted with a nosuid option (?)


I'm trying to enable sudo to the '/sbin/service' command.

The sudo command is SUID root, I even did chmod 4111 earlier to be sure:

---s--x--x 1 root root 93816 Apr 29 20:47 /usr/bin/sudo*


But when I try to run a sudo command to stop/stop a service, I get the error:

Sorry, sudo must be setuid root.



Any ideas?


Thanks
Nat
 
Old 04-30-2007, 06:37 AM   #5
natv
Member
 
Registered: Mar 2006
Posts: 59

Rep: Reputation: 15
Solved my problem..

My shell was "jailed shell" so the actual sudo binary for jailedshell is in a different location. duh


Solution: either use full shell or set suid on the jailed shell binary of sudo


Nat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sorry, sudo must be setuid root kurtdriver Fedora 6 10-22-2008 07:47 PM
"M-Audio Mobile Pre Usb" Soundcard stopped working sonium Linux - Hardware 1 12-21-2006 11:58 PM
how do I get around the "submit passwd" prompt in ubuntu even if I use "sudo"? t3gah Linux - Distributions 1 02-22-2005 04:42 PM
Mom clicked a button and "it stopped working" antiocles Linux - Software 3 01-02-2005 01:35 PM
evolution stopped working - "CORBA" exception thegreatgatsby Linux - Software 3 03-16-2004 07:28 AM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration