LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-28-2006, 08:41 AM   #1
aaron4katie
Member
 
Registered: Dec 2006
Location: Bristol, England
Distribution: Fedora Core 6
Posts: 77

Rep: Reputation: 15
"sudo mount -a" works perfect but permission denied when mounting on startup, why?


Title says it all really.. when i do mount -a as root or using sudo it mounts the drives perfectly.. but on start-up it says permission denied.. Permission denied on /dev/fuse, I've logged on as root and changed the permissions of that file to read/write for all and even removed it but still doesn't work.

On shut-down it also cannot unmount any of my mounted devices properly.. it says they aren't mounted, both if they are or aren't mounted at the time.

Any help? - using ntfs-3g
 
Old 12-28-2006, 08:53 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Normal mounting at startup is controlled by /etc/fstab. I don't know how that relates to using ntfs-3g. Do you have some kind of special script?

Post the contents of /etc/fstab
 
Old 12-28-2006, 09:11 AM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Are the NTFS drives you're accessing local or remote? In any case, the permissions set on the NTFS files can interact -- sometimes rather strangely -- with your Linux permissions.

Also, note that fuse is mounting the files in "user space" (fuse is an acronym for "File System in User Space"), and a user -- not root -- is, I think, needed for the mount.

When you do the sudo, you're in your context, not that of root. What happens if you do a su -; mount -a instead of a sudo mount -a? (I.e., try the mount logged in as root (in root's context).)

Note: I may be blowing smoke here, never having used ntfs-3g but I've had similar problems mounting iso images using fuse. And the umount for the iso image also needed to be done in user space before logoff.

<edit>
Oh, my "work around" was to mount the iso images as part of my session startup.
</edit>

Last edited by PTrenholme; 12-28-2006 at 09:15 AM.
 
Old 12-28-2006, 12:34 PM   #4
aaron4katie
Member
 
Registered: Dec 2006
Location: Bristol, England
Distribution: Fedora Core 6
Posts: 77

Original Poster
Rep: Reputation: 15
This is my /etc/fstab files contents:

Code:
LABEL=/                 /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-sda2         swap                    swap    defaults	0 0
/dev/hda1   		/ntfs/c_drive     	ntfs-3g	rw,defaults,umask=0000	0 0
/dev/hda5   		/ntfs/d_drive     	ntfs-3g	rw,defaults,umask=0000	0 0
/dev/hdb1   		/ntfs/e_drive     	ntfs-3g	rw,defaults,umask=0000	0 0
and using su and then mount -a works exactly the same as with sudo, I just used sudo to show I needed root access.
 
Old 12-29-2006, 08:34 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
OK--you just hit my shallow end. Not knowing ntfs-3g, I don't know what happens when you specify that as the file system.

I had thought that mount would go looking on the device for a filesystem that matched what was in the fstab entry.

Does the ntfs-3g documentation give any clues?
 
Old 12-29-2006, 08:47 AM   #6
aaron4katie
Member
 
Registered: Dec 2006
Location: Bristol, England
Distribution: Fedora Core 6
Posts: 77

Original Poster
Rep: Reputation: 15
I used the instructions from http://www.mjmwired.net/resources/mj...-fc6.html#ntfs but if you take a look, I skipped the first part because it explains ntfs-3g after. I'll look at the documentation if I can.

How do I unmount all..just for now.. umount -a? lol

I found that in man ntfs-3g that usually it won't check for permissions but with 1 line it would, but I'm not using that line. Says to read the readme, but I installed using yum so not too sure where it is, i'll look.

Last edited by aaron4katie; 12-29-2006 at 08:51 AM.
 
Old 01-08-2007, 02:03 AM   #7
Pistal
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
I found this method to work for me. Im running Fedora core 6 and XP Pro.

1. In your Security Level and Firewall configuration, Go to SElinux tab and change SElinux setting to Permissive.

2. Open your fstab, add the following line...obviosley supply your own drive and folder locations.

/dev/YourVolume /mnt/YourFolder ntfs-3g silent,umask=0,no_def_opts,allow_other,locale=en_US.utf8 0 0


You also should not get unmount errors on shut down.

aaron4katie you might have to replace my en_US entry with en_UK

Let me know if you have success...
 
Old 01-08-2007, 09:54 AM   #8
aaron4katie
Member
 
Registered: Dec 2006
Location: Bristol, England
Distribution: Fedora Core 6
Posts: 77

Original Poster
Rep: Reputation: 15
I am also using Fedora Core 6 and XP Pro(gaming only).

I change SE Linux to permissive

and replaces the lines I used for the example you shown but using en_UK instead. For once I didn't get any errors and it automatically mounted the devices. I haven't yet shut down or restarted the computer but I expect it to work OK. If something doesn't work as it should I'll reply again, but if I don't you can assume that it's working fine. I cut a file from one of the hard drives onto desktop and then cut it back to test the read-write access and it worked fine.

Thanks a lot Pistal.
 
Old 01-09-2007, 03:47 PM   #9
Pistal
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
Very Nice !, Glad it worked out. Anytime...


Pistal
 
Old 01-10-2007, 04:33 AM   #10
aaron4katie
Member
 
Registered: Dec 2006
Location: Bristol, England
Distribution: Fedora Core 6
Posts: 77

Original Poster
Rep: Reputation: 15
Just to verify, I had a hard drive error and so it didn't mount that single hard drive, but that was windows fault and the other hard drives still mounted, other than that one time it mounts and unmounts every time, on shutdown or restart a long line is displayed for each unmount but doesn't slow it down and just says something about permissions but unmounts successfully, so I'm not worrying about it.

Thanks a lot.
 
Old 01-11-2007, 10:16 AM   #11
Pistal
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
Im sure most people (including me) would like the ntfs-3g driver working correctly with SElinux set to enforce. According to ntfs-3g, Red Hat fixed the SElinux policy with "selinux-policy-2.4.6-23" but im reluctant to install this yet. Here are the links;

http://www.ntfs-3g.org/support.html#selinux

https://bugzilla.redhat.com/bugzilla....cgi?id=211767
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cifs "mount error 13 = Permission denied" CIFS SUCKS humbletech99 Linux - Networking 40 10-31-2012 08:50 AM
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
"Permission Denied" while accessing ntfs partition in user mode funkymunky Linux - General 3 01-31-2009 08:03 PM
Acrobat Reader "error opening document - permission denied" Robhogg Linux - Software 5 04-25-2008 08:44 AM
"permission denied" when I try to send raw data to the sound device. Travis86 Linux - Hardware 2 10-29-2003 09:08 AM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration