LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Struck at "Configuring Kernel Parameters " in Fedora core 3 booting (http://www.linuxquestions.org/questions/linux-software-2/struck-at-configuring-kernel-parameters-in-fedora-core-3-booting-267593/)

infantpapa 12-17-2004 10:46 PM

Struck at "Configuring Kernel Parameters " in Fedora core 3 booting
 
Hi,
Any one can help me if knows the solution,

I have installed fedora core 3 and changed the etc/X11/xorg.conf to etc/X11/xorg.conf.old for the purpose of changing resolution with "mv" command.
System struck at "Configuring kernel parameters" when i restarted the system. when i tried to enter into terminal by pressing CTRL+c ,oncew again it hanged at "Starting service logging".

Plz help me.
regards.

bm17 12-18-2004 02:05 AM

This is why I hate systems that automatically boot to the display manager. Did you put a new /etc/X11/xorg.xonf file in place after you moved the old one? In any case, it sounds like the X server is failing to start and the display manager startup code is in a loop trying to restart it. Can you login remotely (via rsh, ssh, or telnet) and replace the old config file? Or look at the X.org log file in /var/log/ to see what the problem is? If you can't get a remote login you can always tell grub to start the kernel but only proceed to runlevel 3 (no X).

infantpapa 12-18-2004 04:06 AM

Thanks for ur help,
But my system is not even able to boot into terminal(not X), then how can i do the things u said?

bm17 12-18-2004 04:43 AM

You mean that you don't even get to grub? Before the kernel is even loaded?

infantpapa 12-18-2004 06:29 AM

Iam getting grub , but not able to boot into the terminal . It is not showing any responce after showing the message--
"Configuring Kernel Parameters "
Thats it.
I have not placed any new xorg.conf file.I have renamed it as xorg.conf.old previoulsly thats why iam getting problem.

Can u tell me how to get atleast into terminal?

Regards

bm17 12-18-2004 01:09 PM

You need to halt the boot process at grub and add "runlevel=3" to the kernel parameters line. I don't know what varient of grub you have (graphical or otherwise) but you can learn the details from googling for "grub kernel runlevel". Runlevel 3 stops the boot process before X starts up. I think you can put "emergency" on the command line as well.

Gavin Day 02-19-2005 07:50 AM

stuck at configuring kernel parameters after installing FC 2
 
I've a similar problem, I've installed Fedora Core cds 1 & 2 (of 4). The message comes that all I need to do is reboot. I do that then Grub gets stuck with the following message-

configuring kernel parameters: (with flashing cursor)

Presumably some user input is required at this point as the boot up procedure doesn't continue beyond this point.

Any suggestions?

mammarin 03-06-2005 03:25 AM

Stuck at "Configuring kernel parameters"
 
Hi,

I came across the same problem after making some changes in the screen resolutions on /etc/X11/xorg.conf file on my Fedora core3.

I then boot the machine with Fedora DVD
- typed in "linux rescue" at the boot: prompt
- clicked through a few questions about language, network service, etc
- at "Rescue" screen, select "Continue"
- pressed <return> to get a shell
- typed "chroot /mnt/sysimage" and then go straight back to the file I made changes (which caused this problem): /etc/X11/xorg.conf, in this case I change the content of the file to its original state.
- "exit" (from root)
- "/sbin/shutdown -r now"
- (another) "exit"

The system got reboot, and this time without stay hanging at "Configuring kernel parameters" !!

Hope this help.

nick1 04-05-2005 12:04 PM

thank you so much - you saved my butt! :D

TAshkar18 05-05-2005 08:30 PM

Re: Stuck at "Configuring kernel parameters"
 
Quote:

Originally posted by mammarin
Hi,

I came across the same problem after making some changes in the screen resolutions on /etc/X11/xorg.conf file on my Fedora core3.

I then boot the machine with Fedora DVD
- typed in "linux rescue" at the boot: prompt
- clicked through a few questions about language, network service, etc
- at "Rescue" screen, select "Continue"
- pressed <return> to get a shell
- typed "chroot /mnt/sysimage" and then go straight back to the file I made changes (which caused this problem): /etc/X11/xorg.conf, in this case I change the content of the file to its original state.
- "exit" (from root)
- "/sbin/shutdown -r now"
- (another) "exit"

The system got reboot, and this time without stay hanging at "Configuring kernel parameters" !!

Hope this help.

Hello,

I need help doing this, i didn't change any files, i just downloaded the fedora core files from fedora core site and burned them to CD (32 bits) and then installed it and wehn rebooted it hanged, I tried your way, i typed chroot/mnt/sysimage and then typed exit, because i don't know what do with /etc/X11/xorg.conf. Can anoyone help me??

thanks

Gripper 05-26-2005 01:30 PM

Fedora core 3 on asus terminator C3 with cle266 northbridge. Boots fine from CD and goes through X without a hitch but after install it chokes on "kernel parameters" which sounds like X is the problem as noted above. What changes from the configuration that is used on CD 1 to the bootable installed version on hda? Is it the video driver?

Gripper 05-30-2005 06:39 AM

It is the via driver. X will boot with the VESA driver but video play back is horrible. Has anyone got the VIA driver to work with the cle266 northbridge (integrated S3/unichrome graphics)?

DeDannan 06-03-2005 05:42 PM

Had same problem after moving disk to different system due to hardware changeson system.

Resolution: At Grub prompt press Enter.
Highlight your boot config & enter 'e' (Edit cmd)
Delete the RHGB & quiet options and replace with '3'
Enter b (boot)
System will start to boot & any hardware differences from config on disk will be detected. you will get options to delete any missing hardware from config & also options to add any new hardware detected. When this is completed boot process should continue normally.


All times are GMT -5. The time now is 11:24 AM.