LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-18-2003, 08:01 PM   #1
evilhomer
LQ Newbie
 
Registered: Jul 2003
Distribution: suse 9.2 pro
Posts: 14

Rep: Reputation: 0
strange java error w/ mozilla


Hello,
I installed Mozilla 1.4, and needed java. I installed the lastest jre from sun.com 1.4.1. Everything seems to be fine, but when i start mozilla i receive this error, and java doesn't work:

LoadPlugin: failed to initialize shared library /usr/java/j2re1.4.1_03/plugin/i386/ns610/libjavaplugin_oji.so [/usr/java/j2re1.4.1_03/plugin/i386/ns610/libjavaplugin_oji.so: undefined symbol:
GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

I'm totally lost here, can anyone assist?
 
Old 07-20-2003, 03:23 AM   #2
DigitalTygrrr
Member
 
Registered: Apr 2003
Location: /home/BillyGoatStrut
Distribution: Ubuntu, Debian "Sarge", Mac OS X
Posts: 110

Rep: Reputation: 15
maybe you've already sorted this out. In case not...I was having the same probs a couple of days ago and I read the you either have to have sun java 1.4.2 or blackdown java. I looked for the sun one and couldn't find it. here's the blackdown .

hope this works for you.
 
Old 07-21-2003, 09:03 PM   #3
evilhomer
LQ Newbie
 
Registered: Jul 2003
Distribution: suse 9.2 pro
Posts: 14

Original Poster
Rep: Reputation: 0
i figured it out

when you goto sun.com/java and look for jre it wants you to install 1.4.1 so i did.

turns out you need to try to download the 1.4.2 SDK, then select the option for just JRE and you'll find 1.4.2.

*has* to be 1.4.2

thanks for your input though, if I hadn't found that SDK trick i'd still be looking.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Blam: no mozilla found - I'm positive I have Mozilla installed. Strange. cillm527 Linux - Software 2 07-25-2005 05:49 PM
Strange Firefox 1.0 Java Error Fedora 2 opioid Linux - Software 2 12-22-2004 09:56 AM
Java for Mozilla and Mozilla-firebird Problem, Please help londonboi Linux - General 5 01-08-2004 06:07 AM
Java in Mozilla Firebird and Mozilla saurya_s Linux - Software 1 12-08-2003 02:12 PM
Mozilla java plugin no go kills Mozilla skinpainting Red Hat 13 11-30-2003 12:30 PM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration