LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-10-2005, 07:23 AM   #1
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Strange bootsplash behaviour


Hi!

I just compiled kernel 2.6.11.7 on my SUSE 9.1 system. I patched it with the bootsplash patch (http://www.bootsplash.de/files/boots....4-2.6.11.diff ). Everything went fine, apart from a very weird behaviour during boot:

This in my menu.lst:
Code:
title Linux-2.6.11.7
    kernel (hd0,4)/boot/vmlinuz-2.6.11.7 root=/dev/sda5 vga=0x31a splash=verbose desktop showopts
    initrd (hd0,4)/boot/initrd-2.6.11.7
But the bootsplash that comes up is in silent mode. And I find this in /var/log/boot.msg:
Code:
<4>Kernel command line: root=/dev/sda5 vga=0x31a desktop splash=silent
I checked my config file in /etc and /boot, but non of the contains the above line. Did I compile this into my kernel without knowing? Or is this a hidden paramter in initrd?

Please help me out, I would like to understand this.
 
Old 04-10-2005, 08:18 AM   #2
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
one question.
why did you bother patching bootsplash into the kernel if you are just going to set splash=verbose?
splash=silent is the option you want if you want it to show a bootsplash screen.

so infact it would seem that you don't want the bootsplash showing. you want to watch the boot process, don't you?
In this case, why did you patch the kernel with bootsplash? the idea would have been to remove bootsplash from the kernel.
 
Old 04-10-2005, 08:25 AM   #3
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
Sorry, but verbose has a bootsplash image on which the boot-messages are displayed. Yes, I would like to have this (not just a black screen, which would be splash=0). I know that there are more important things in life and linux, but I simply would like to understand this behaviour.
 
Old 04-10-2005, 08:35 AM   #4
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
that isn't what i meant.
why did you install the bootsplash stuff.
no bootsplash is when you watch the messages.
removing the splash=something line might solve this problem.
recompiling the kernel without bootsplash support would almost definitly do it.
 
Old 04-10-2005, 08:43 AM   #5
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
I understood you perfectly!

There are 3 possible boot displays:

1. no splash, a simple text console is shown.
This does not require the bootsplash-patch, right!

2. splash= silent
Instead of showing messages, a more or less nice graphical picture is shown. Sometimes with a progress-bar. I don't want this, but there is a 3rd alternative:

3. splash=verbose
In this variant, the boot messages are shown just like in #1, but with an underlying picture. In my case this is a cute tux that I downloaded from www.bootsplash.org
Have a look on that site and you'll see what I mean. This is what I want and it is called 'verbose'. And it requires the patch.

To rephrase my question (makes it more general):

Why does the kernel receive a command-line that I did not sent to it? Where did it come from and what happend to my parameters?
 
Old 04-10-2005, 08:20 PM   #6
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
this is going to sound like a dumb question, but which bootloader are you using? you did edit the right config file and install the right bootloader, didn't you?

i made that mistake a while ago.

if that was all done right, try installing this: http://kat.sourceforge.net/
it lets you search through text files, and you can run a search for the string "splash=silent" to find and change the offending file.
 
Old 04-11-2005, 02:48 AM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
I am using grub. The config file is /boot/grub/menu.lst.

Thanks for the tip with kat. I may try that later. I have done a content-search using find and it did not find the string in any of the files in /etc and /boot.
 
Old 04-11-2005, 02:56 AM   #8
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
try running this again:
Code:
grub-install /dev/hda
the /dev/hda bit is assuming that your harddrive is hda, it could also be /dev/sda or /dev/hdb or something like that.
 
Old 04-11-2005, 03:12 AM   #9
houler
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1, Kernel 2.6.14.4 (custom)
Posts: 166

Rep: Reputation: 30
maybe that patch is is incompatible with the newest kernel?
 
Old 04-11-2005, 03:38 AM   #10
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
I think I am getting closer...

- A fresh grub install didn't help.

- The patch was applied without any errors, still it could be something wrong with it...

- When I exit the graphical grub menu (SUSE uses a file called gfxmenu to display a graphical screen) and use the 'dos-style' menu-mode to boot instead, the behaviour is correct (the verbose splash is loaded). If I use the graphical menu however, the wrong kernel command line is submitted. Strange!

Thank for your support guys!
 
Old 04-11-2005, 03:51 AM   #11
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
I think SUSE demands that you use splash=silent. Its probably hidden in a random config file, maybe event in initrd or vmlinuz. I would try installing kat and searching for it, or even recompiling the kernel and checking that the correct toggles were chosen.

what does the top section of your menu.lst file say, the bit above each OS section.
 
Old 04-11-2005, 04:51 AM   #12
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
Code:
color white/blue black/light-gray
default 2
timeout 8
gfxmenu (hd0,4)/boot/message
Haven't had time to search again for the occurrence of 'splash=silent', I'll tell you about this later.
 
Old 04-11-2005, 05:15 AM   #13
Gay R0b0t
Member
 
Registered: May 2004
Location: Sydney, Australia
Distribution: SUSE 9.3
Posts: 127

Rep: Reputation: 15
i just looked in /boot/message (used command 'cpio -i </boot/message' to extract it) and didn't find anything useful.
just some config files and a help file (which only repeated what we have already tried).

you might want to look inside yours to determine if there is anything relevent.

Edit:
I'm running SUSE 9.2 (without any major modifications), and decided to try setting splash=verbose to determine whether I have the same problem.
The steps I took were:
1. Open /boot/grub/menu.lst
2. Change splash=silent to splash=verbose in the SUSE section.
3. Save menu.lst
4. Re-install grub (command: grub-install /dev/hda)
5. Reboot.

When it rebooted, it showed the verbose screen. The fact that you installed the bootsplash patch might be working against you here. Try re-installing the vanilla kernel (the one that came with suse), or even try this one (its the one i use) kernel-default and the non-gpl bit (both should be installed) kernel-default-nongpl

by the way, im using apt-for-suse to keep stuff up to date.

Last edited by Gay R0b0t; 04-11-2005 at 05:28 AM.
 
Old 04-11-2005, 08:57 AM   #14
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Original Poster
Rep: Reputation: 58
Smile solved

For some strange reason, I have used a tab instead of a space between the vga and the splash parameters. This seemed to cause grub to ignore all following parameters and to use a default, which seemed to be splash=silent. I did not see this in my favourite editor pico, only when I used kwrite.

Thanks again for the help and sorry for the inconvenience!
 
Old 04-11-2005, 03:04 PM   #15
houler
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1, Kernel 2.6.14.4 (custom)
Posts: 166

Rep: Reputation: 30
Hi,

How did you get your progress bar to work?

I can't seem to get the progress bar working on slackware 10.1:

the Image w/o progress bar and verbose mode work fine, I don't have the slightest clue on how to get the progress bar working...

--EDIT--

I got it to work, I just read the docs.

Last edited by houler; 04-11-2005 at 04:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behaviour Anmol Suse/Novell 2 10-27-2005 11:05 PM
strange xrandr behaviour? devUrandom Linux - Software 1 03-15-2005 10:27 AM
SCP strange behaviour sbalasuriya Linux - Software 0 09-21-2004 10:50 AM
Strange USB behaviour powadha Slackware 0 12-20-2003 03:24 PM
Strange Behaviour mikeyt_3333 Linux - General 4 08-06-2001 03:07 PM


All times are GMT -5. The time now is 04:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration