LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-19-2003, 07:39 PM   #46
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46

okay. so that 60 GB one is your C:\ drive, right? which one on your list looks like the H:\ drive? is the H:\ drive the one on the 1st hard drive?
 
Old 10-19-2003, 07:53 PM   #47
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
umm

no no, the 60gig is my H:

the 15 gig is what i use for the OS.

sorry bout the confusion
 
Old 10-19-2003, 08:07 PM   #48
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
alrighty then. at the command line type these commands:

1. su
<enter root password>

2. mkdir /mnt/c
3. mkdir /mnt/h
4. kwrite
4a. Click File > Open
4b. in Location on the bottom, type this: /etc/fstab
4c. enter these entries at the bottom:

Code:
/dev/hda2     /mnt/c     ntfs     auto, owner, umask=0222, ro 0 0
/dev/hdb1     /mnt/h     ntfs     auto, owner, umask=0222, ro 0 0
4d. Click File > Save
5. mount /dev/hda2
6. mount /dev/hdb1

now you're windows partitions are mounted. you can add hard drive icons to your desktop now. i use kde, so, i'll tell you how to do it in kde.

1. right click on an open space on your desktop
2. choose New > Hard disc from the context menu
3. The default tab is the General Tab. here you can give the icon a name that will be displayed on your desktop. give the icon a name like Windows C (or whatever you want).
4. click the Device Tab and from the device dropdown box, choose "/dev/hda2"
5. Click the Ok button
6. repeat from step one, except give the name of this one Windows H (or whatever you want) in step 3 and choose "/dev/hdb1" in step 4.

you can click on those icons now and see your windows files. you will be able to use your mp3s and other datafiles, you just won't be able to make changes to them or save anything on those drives. why? because it's very, very, very dangerous. did i mention that writing to ntfs partitions is very dangerous?
 
Old 10-19-2003, 08:12 PM   #49
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
lol, i'll give that a shot

so if i run mp3's and movies from the ntfs partition am i gonna be alright??
 
Old 10-19-2003, 08:17 PM   #50
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Re: lol, i'll give that a shot

Quote:
Originally posted by jasonmcneil0
so if i run mp3's and movies from the ntfs partition am i gonna be alright??
yes, you should be okay. just remember like if you're going to listen to your mp3s, you can't do stuff like change the id3 tags because we set the drive to read only. that is safe for ntfs. setting your ntfs permissions for read-write is not safe at all.
 
Old 10-19-2003, 08:24 PM   #51
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
ok, more

i did the kwrite, and when i go back it tells me that i have errors in line 9

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda2 /mnt/c ntfs owner, unmask=0222, ro 0 0
/dev/hdb1 /mnt/h ntfs owner, unmask=0222, ro 0 0

, when i tab in kwrite , it leaves what looks like a period would this cause the error:

which is:

[root@localhost jason2]# mount /dev/hda2
[mntent]: line 9 in /etc/fstab is bad
[mntent]: line 10 in /etc/fstab is bad
mount: can't find /dev/hda2 in /etc/fstab or /etc/mtab

/Jason
 
Old 10-19-2003, 08:25 PM   #52
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
shit that looks messed up

i dunno if ur gonna be able to pick an error outta there or wha
 
Old 10-19-2003, 08:34 PM   #53
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
try getting rid of the spaces in those lines after the commas.

/dev/hda2 /mnt/c ntfs auto,owner,umask=0222,ro 0 0
/dev/hdb1 /mnt/h ntfs auto,owner,umask=0222,ro 0 0

and did you install that ntfs kernal support module?
 
Old 10-19-2003, 08:36 PM   #54
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
yip i did install that

yea i did install the NTFS, i will try without the spaces
 
Old 10-19-2003, 08:41 PM   #55
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
ok, taking out the spaces worked

now a diffferent error

[root@localhost jason2]# mount /dev/hda2
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost jason2]# mount /dev/hdb1
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
or too many mounted file systems

u know what would cause this man??

/Jason
 
Old 10-19-2003, 08:44 PM   #56
oobe
Member
 
Registered: Sep 2003
Distribution: slackware
Posts: 83

Rep: Reputation: 16
there is a binary file inside the amsn.tar.gz in a directory called msn i cant remember what it is called just copy it somewhere and execute it
 
Old 10-19-2003, 08:57 PM   #57
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
thanks oobe

all is good now, i was missing a file which i got and i can install fine now. and Gaim is fine for msn also.

/Jason
 
Old 10-19-2003, 08:59 PM   #58
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Re: ok, taking out the spaces worked

Quote:
Originally posted by jasonmcneil0
now a diffferent error

[root@localhost jason2]# mount /dev/hda2
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost jason2]# mount /dev/hdb1
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
or too many mounted file systems

u know what would cause this man??

/Jason
it looks like it's because it's SFS filesystem which is an encrypted filesystem for windows/dos. my guess is that you'll have to boot into windows to disable filesystem encryption. but before that, in your fstab, you could try to change the filesystem on the entries from ntfs to auto and see if it will mount. i doubt it though.
 
Old 10-19-2003, 09:06 PM   #59
jasonmcneil0
Member
 
Registered: Oct 2003
Posts: 141

Original Poster
Rep: Reputation: 15
hmmm

i know for a fact i am not using file security in windows.

is there another way to do this, may a program wich i capable?? thanks for everything so far mega.


/ Jason
 
Old 10-19-2003, 09:14 PM   #60
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well i don't really know. i was just looking back at your fdisk output and it shows 2 partitions with a file system of SFS.

like i said earlier, you could try in /etc/fstab to change ntfs to auto and see if it will mount. but i don't think it will or if it does, i'm not sure how this will affect those partitions. i'd seriously suggest that you check out your windows configuration as you might not be using security while you run windows, but maybe you have something where when windows shutsdown, you have it encrypt it's parititions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get amsn and tcl/tk to intsall Gnixon Linux - Newbie 5 09-26-2004 03:10 PM
TCL/TK installation for amsn salmanucit Linux - Software 1 09-23-2004 12:45 PM
AMSN Interface Isn't Working after install of Tcl/Tk on RH9 kingofcamel Linux - Software 0 06-28-2004 09:48 PM
amsn says tcl/tk not correctly installed? please help! phiqtion Linux - Newbie 2 05-29-2004 01:08 AM
How To Install TCL? (For amsn messenger) Nukem Linux - Software 1 12-05-2003 10:21 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration