LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-28-2004, 09:13 AM   #1
jhecht
Member
 
Registered: May 2004
Location: NYC
Distribution: Puppy Linux - it's dog-gone great!
Posts: 99

Rep: Reputation: 16
Still can't write to floppy - why?


I've still got a problem that my floppy is recognized as read-only, even though the 'puter formatted it (DOS). This is in Slackware 9.1, with Gnome desktop.

I've looked at /etc/fstab & /etc/mtab and it seems the floppy is listed correctly. I get an 'invalid parameters' message when I try to drag-n-drop onto the floppy desktop icon.

In fstab, the line for the floppy reads:
/dev/fd0 /mnt/floppy auto noauto,owner 0 0

In mtab, the line for the floppy reads:
/dev/fd0 /mnt/floppy umsdos rw,nosuid,nodev 0 0

Can anyone help me with this? It would be VERY useful to be able to write to floppy!
Also, if I change 'noauto' to 'auto' in fstab, will the floppy auto mount? And if so, does the same apply to the CD?

TIA for your help!

Last edited by jhecht; 06-28-2004 at 09:14 AM.
 
Old 06-28-2004, 09:57 AM   #2
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
You will want the fstab line to read
noauto,user
instead of
noauto,owner

Right now, only the owner (probably root) can write to it, and yes, the auto means to automatically mount, but I never use it.

RO
 
Old 06-28-2004, 10:02 AM   #3
jhecht
Member
 
Registered: May 2004
Location: NYC
Distribution: Puppy Linux - it's dog-gone great!
Posts: 99

Original Poster
Rep: Reputation: 16
Quote:
Originally posted by RolledOat
You will want the fstab line to read
noauto,user
instead of
noauto,owner

Right now, only the owner (probably root) can write to it, and yes, the auto means to automatically mount, but I never use it.

RO
But, but - I am root - this is an experimental machine, I am the ONLY user. I will try the changes however. As I prefer to work from a desktop GUI (Gnome), I always want floppies and CD's to auto mount, and auto unmount. Is this possible?

UPDATE!
I tried writing those changes into fstab and re-booting. Nothing changed, I stll get 'invalid parameter' when doing a drag-n-drop to the floppy icon. Nor does the icon appear when I insert then floppy - a la Mac. Isn't that what auto mount is supposed to do?

fstab now reads:

/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 auto,user,ro 0 0
/dev/fd0 /mnt/floppy auto auto,user 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Any comments, suggestions? Thanks!

Last edited by jhecht; 06-28-2004 at 10:22 AM.
 
Old 06-28-2004, 10:17 AM   #4
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
It doesn't have to be root. Just for grins, if you right click on the floppy icon, properties, who is the owner. It may not be root, however, root could write to it, at least with vi and the w! command, but I regress. I think that the auto is automount at boot. I am not sure what the line should read like for supermount, which is dynamic mount. I do have mandrake installed on this machine, supermount enabled, and the floppy line there reads like this. Decoding it, and testing it, I can't help there...

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso88
59-1,sync,codepage=850 0 0

(Note: it is all on one line)

RO
 
Old 06-28-2004, 10:33 AM   #5
jhecht
Member
 
Registered: May 2004
Location: NYC
Distribution: Puppy Linux - it's dog-gone great!
Posts: 99

Original Poster
Rep: Reputation: 16
Quote:
Originally posted by RolledOat
It doesn't have to be root. Just for grins, if you right click on the floppy icon, properties, who is the owner. It may not be root, however, root could write to it, at least with vi and the w! command, but I regress...
RO
I right-clicked on the floppy icon, selected 'properties', then selected the 'permissions' tab. Got a dialog line that said "Permissions for 'floppy' could not be determined."

I don't think I could use your fstab lines in my setup, but it's useful to know that 'supermount' is what I'm trying for. Thanks!
 
Old 06-28-2004, 10:51 AM   #6
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
http://www.linuxquestions.org/questions/history/182229

shows how to test if you have supermount built into the kernel. One last stupid question thought...you don't have the floppy read/write tab in the read only position? Hey, gotta ask the stupid questions....

RO
 
Old 06-28-2004, 11:36 AM   #7
jhecht
Member
 
Registered: May 2004
Location: NYC
Distribution: Puppy Linux - it's dog-gone great!
Posts: 99

Original Poster
Rep: Reputation: 16
RO>you don't have the floppy read/write tab in the read only position? Hey, gotta ask the stupid questions....

That's not stupid - it's the first thing to check - and it was the first thing I checked before posting here. The tab is closed (no hole) which is the read-write position. Same as an audio cassette or vcr tape.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't write to floppy TxLonghorn Linux - Newbie 4 03-17-2005 08:03 PM
can't write to the floppy ??!?? safrout Mandriva 2 11-16-2004 12:08 PM
Cannot write to Floppy, even as root Bob Moore Linux - Hardware 7 07-22-2004 10:22 AM
Can't write to floppy PionexUser Linux - Newbie 3 07-20-2003 12:13 AM
Write to a CD-RW like a floppy... harrkev Linux - General 1 10-26-2001 12:29 PM


All times are GMT -5. The time now is 03:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration