LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-22-2004, 04:23 PM   #1
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Starting xdm at boot in Debian Sarge


Hi.

I installed a barebones Woody system, upgraded to Sarge, and then started installing packages.

I now have XFree86 and KDE installed, along with the nVidia drivers for my vid card.
Problem is this:

At bootup, it progresses fine to:
Starting X Display Manager... (or some such - tries to start X)

Then my screen flickers three times, and I'm taken back to a shell login. No error given. I can switch to VT7, but there's just a cursor in top left.
So X failed without explaining why.

If I startx, it craps out with "no screens found"

But, if I modprobe nvidia, and then startx, everything's peachy - no problems at all.

Weird thing is, in the boot message, I get the "license NVIDIA taints kernel" message - so apparently, it IS loading the driver before it tries its initial xdm call.

I've also done a depmod, to ensure the kernel realizes nvidia exists, and make some attempt to resolve its dependencies... not sure if it would help, but couldn't hurt.

How do I get X loading properly at boot?

Any ideas would be appreciated!

--Rounan
 
Old 02-22-2004, 04:31 PM   #2
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
well, recheck your XF86Config file, make sure that you "monitors" section is setup correctly, you have "nvidia" set as driver, deleted all instances of Dri and GLcore and made sure glx is uncommented

nvidia drivers tend to avoid leaving error messages when starting the desktop manager
 
Old 02-22-2004, 04:59 PM   #3
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Original Poster
Rep: Reputation: 30
XF86Config-4:

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

(...)

Section "Device"
Identifier "nVidia GeForce Ti4200"
Driver "nvidia"
Option "NoLogo" "true"
Option "DigitalVibrance" "2"
Option "CursorShadow" "true"

EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-107
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia GeForce Ti4200"
Monitor "Generic Monitor"
DefaultDepth 24
(...)
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

It all looks good to my eyes, and the same config works on a subsequent "startx" - just not at boot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is the boot log in debian sarge ?? copter Debian 6 04-02-2006 04:27 AM
Using XDM with fluxbox on sarge linuxmandrake Linux - Software 1 11-14-2005 06:58 AM
Debian Sarge boot disk r3dhatter Debian 5 02-19-2005 03:03 AM
Just installed debian with a desktop manager, don't want xdm starting. Royle Linux - Newbie 2 01-09-2005 07:46 AM
Boot loader Debian Sarge tungsten Debian 16 04-14-2004 07:27 AM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration