LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-15-2003, 03:23 AM   #1
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Rep: Reputation: 15
Starting Fluxbox....


I have read all the threads and tried many different methods......

I have been trying to run fluxbox for about 10 hrs now.....

5 hrs last night......and about 5 hrs today.......

I even formatted my computer to remove the Ximian Desktop thinking there was a conflict

I also have tried adding the fluxbox script in usr/local/bin

I have tried adding a case script in the KDE windows manager file....

I tried adding the fluxbox script in many locations.....

I tried installing the fluxbox redhat 9.0 RPM package the is able to add fluxbox to the desktop manager. I am not able to do this because of three dependencies. When I tried to install the RPM files containing the dependencies it shows I have the package pre-installed. I also downloaded red-carpet. I tried installing the fluxbox rpm with red-carpet. It stated it could not find the dependencies. I also tried other rpm managers....i got rpm dependencies when trying to install rpm managers. I have the latest kernel, RH9.0, updated packages, and I have gnome and kde interface and developer packages installed. Some of the dependencies for the fluxbox rpm to make a fluxbox wm option available are already on my computer. The redhat would have to downgrade the package. Is there some kind of link I need to create?

I am starting to become discouraged. Something this simple should be able to accomplish.

I have literaly spent 10 hours on trying to install this Fluxbox.

It is not all time waisted.....I got rid of Ximian Desktop (which slows your system like crazy), got my up2date working, learned about windows managers and desktop managers, and learned some scripting stuff.

I am hoping this fluxbox is going to be all as good as I am hoping it is. I want to get one of the resourse things on the side and have it set-up sweet. I also want to create different interfaces for different users. Such as an interface that brings everything for doing school work on one desktop. Then another interface/user for internet browsing. And of course a work interface for doing work. I'm not really shure how it is going to work once I get to the point of getting fluxbox installed. Another big reason I am gonna use fluxbox is because I have only 64mbs of memory. Which causes my computer to run slow... Although, I have read on LQ that fluxbox will still take all that memory up.

Sorry for the long post, I am just excited to get fluxbox working. Any suggestions you guys got for me? I am using a grapghical desktop manager, that is given as default with RH9.

Would switching to Slack prevent all these dependencies? How are the packages in slack different than RH? I have been interested in switching to slack.... I just have to take the time to download it, burn it, partition, and install it. I do need to get some work done that I have been postponing to get fluxbox running.

Let me know what you guys think I am doing wrong. I have tried everything I can think of, including the stuff on LQ and on fluxbox.org.
 
Old 12-15-2003, 03:44 AM   #2
rile
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
1. Download the tarball and extract it, then ./configure && make && make install (as root)

2. Create a file called .xinitrc in your home directory of the user you want fluxbox to start on. (Just type "pico .xinitrc" when you are in the home directory.

3. Edit .xinitrc and put the line "exec /usr/local/bin/fluxbox" in the file. Without "" of course.

4. "chmod 700 .xinitrc" as root

5. "mkdir .fluxbox" in your home directory, so all your settings can be saved...

I hope this helped you
 
Old 12-15-2003, 04:16 AM   #3
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
Rile,

I just tried what you suggested. Instead of pico I used vime. I did not put an ! in the firstline of the .xinitrc file. I am not sure if that is needed. I already have the package installed. One thing I noticed for this intall was there is no usr/local/binfluxbox file....I created it my self....there is a /usr/local/bin/startfluxbox file created from make install though..... I think this has not worked because my computer starts on run-level 5 and has a graphical desktop manager. I think I have a good chance of getting it working if I can install the rpm package. I have the dependency problem though. When I search for the dependencies on yahoo, download them in rpm format, then try to install them...i receive a message stating there already installed and with a higher version. Should I pursue trying this rpm or pursue trying a scipting method. Has anybody ran this on a RH9 distro? There has to be some reasonable way to do this. Also, I watched the install closely, there were no errors, so I did not re-install it on this attempt. This is installed under the root, correct? Please let me know about the dependencies or a method of choosing fluxbox from the gdm.... I have changed some of the Xsession, added a gdm scipt called fluxbox (no selection was given), also I have added fluxbox as one of the wm's in a file located in the kdm folder.
 
Old 12-15-2003, 05:22 AM   #4
rile
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
What happens if you type /usr/local/bin/startfluxbox in shell, instead of startx?
 
Old 12-15-2003, 01:46 PM   #5
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
I tried executing the startfluxbox script....it then gives me an error saying that X is not running. Although, if I hit [control + alt + f7] it will go in to the gui mode.
 
Old 12-15-2003, 01:50 PM   #6
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
Also, I just tried in the terminal and got a different error:

$ startfluxbox
Failed to read: session.tabs
Setting default value
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.numLayers
Setting default value
Failed to read: session.slitlistFile
Setting default value
Failed to read: session.groupFile
Setting default value
Failed to load groupfile:
apps file failure
Failed to read: session.screen0.imageDither
Setting default value
Failed to read: session.screen0.sloppywindowgrouping
Setting default value
Failed to read: session.screen0.workspacewarping
Setting default value
Failed to read: session.screen0.desktopwheeling
Setting default value
Failed to read: session.screen0.antialias
Setting default value
Failed to read: session.screen0.autoRaise
Setting default value
Failed to read: session.screen0.clickRaises
Setting default value
Failed to read: session.screen0.rootCommand
Setting default value
Failed to read: session.screen0.resizeMode
Setting default value
Failed to read: session.screen0.menuAlpha
Setting default value
BScreen::BScreen: an error occured while querying the X server.
another window manager is already running on display %s.
:0.0
Error: Couldn't find screens to manage.
Make sure you don't have another window manager running.


What do you suggest?
 
Old 12-15-2003, 01:57 PM   #7
rile
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
You cant run KDE or gnome when you execute the command. Just exit X with ctrl + alt + backspace and then rthe command again. If this works, just put the command in .xinitrc, then it will start when you run startx.
 
Old 12-15-2003, 02:12 PM   #8
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
I just tried this..... it exits the GUI and goes into the grapghical login screen.....

I then went to the command line......

It tells me that I have to startx.......

I typed startx......

It gave me a thing saying it couldnt start and told me to delete something like startx.0 or something like that file which is loacated in a temp directory.....

Should I delete this?
 
Old 12-15-2003, 02:16 PM   #9
rile
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
Don't type startx, type /usr/local/bin/startfluxbox instead, or have you tried this? I don't know how to do in that case, i've told you all i know

Edit: Put /usr/local/bin/startfluxbox in .xinitrc and make sure you chmod it, the try to exit X, else, try to reboot, it should read from the file and start fluxbox, at least, thats what i think :

Last edited by rile; 12-15-2003 at 02:22 PM.
 
Old 12-15-2003, 02:22 PM   #10
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
Thank you for your help.....i did try running the /usr/local/bin/startfluxbox.....also the /usr/local/bin/fluxbox.....

I did this before and after starting X.

WHat if I boot up in a run level 3?

Could that work?
 
Old 12-15-2003, 02:23 PM   #11
rile
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
Try that, whats the difference?
 
Old 12-15-2003, 02:37 PM   #12
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Try putting this as ~/.xinitrc

Code:
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# start some nice programs

exec fluxbox
Then, stop X and your graphical login-manager
(no idea how to do in RH, I only tried skill -9 gdm
on RH once, but it came back up). init 3 might
do the trick.

Then run startx



Cheers,
Tink
 
Old 12-15-2003, 04:55 PM   #13
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Original Poster
Rep: Reputation: 15
The script .xinitrc script from Tinkset worked beautifully. I changed my Init seetings in the /etc/inittab file from 5 to 3, mad the .xinitrc script Tinkster had.... and then typed in start x....

Great, it works now I have to tune it up to how I want it.

Thanks for the help.

 
Old 12-15-2003, 05:02 PM   #14
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Pleasure mate ... was it worth an affero? :)


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting programs maximized in FluxBox mjjzf Linux - Software 1 10-16-2004 10:55 AM
Starting programs in Fluxbox or Windowmaker BajaNick Linux - Software 3 03-03-2004 02:31 AM
starting fluxbox tombomb300 Linux - Software 8 11-20-2003 01:06 AM
starting fluxbox in rh9.0 shiny Linux - Software 6 05-31-2003 01:44 PM
Starting Fluxbox rdanda Slackware 10 05-01-2003 01:58 PM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration