LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-29-2003, 08:02 PM   #1
tombomb300
Member
 
Registered: Sep 2003
Posts: 49

Rep: Reputation: 15
starting fluxbox


ive installed it, now i need to know how do i get it start up? when i type "startx" i get kde. and fluxbox is not in the kde desktop switch Utility, how do start it from command line?
 
Old 10-29-2003, 08:06 PM   #2
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
try exec fluxbox
 
Old 10-29-2003, 08:12 PM   #3
tombomb300
Member
 
Registered: Sep 2003
Posts: 49

Original Poster
Rep: Reputation: 15
nope all that seems to do is exit , like the exit logout command
 
Old 10-29-2003, 08:57 PM   #4
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
This is from the online documantation....


2.1.3. Running Fluxbox

It's all nice and good if you have it installed, but what use is it if you can't run it?

There are two generally different ways to start X11 (and thus Fluxbox). The traditional way is using the command startx. The other way is using a graphical login manager (also called "display manager"). The most common display manager is xdm which is part of the XFree86 distribution. The display manager provided by Gnome is called gdm, the one from KDE is kdm.

If X11 is started the former way (via startx), the file that is important is called .xinitrc and resides in your home directory. In the case of starting via a display manager, the file is .xsession which resides at the same location.

The next step is to find the executable for Fluxbox. For most people, this is /usr/local/bin/fluxbox. Now you need to edit (or create) the file I just mentioned. Just put the following line at the bottom of the file:

exec /usr/local/bin/fluxbox

Change the /usr/local/bin/fluxbox to where ever your Fluxbox executable is, the above is the default location when compiling from source. Once that is done, save it and close whatever editor you used to edit it. Now you need to run the following command if you use startx:

$ chmod 700 .xinitrc

In the case of .xsession that is not needed. In both cases, you should create the directory in which Fluxbox stores its configuration:

$ mkdir .fluxbox

If you don't create it, when you exit Fluxbox and restart, you will lose all your settings (the directory is not auto-created unfortunately).
----------------------------------------------------------

here is more detailed info if you choose to use graphical logon...


4. How do I add fluxbox to my GDM sessions menu.

Create the file: /etc/gdm/Sessions/fluxbox with contents:

#!/bin/sh
#
# /etc/gdm/Sessions/fluxbox
#
# global fluxbox session file -- used by gdm

exec /etc/X11/Xsession /usr/bin/fluxbox

Of course, change /usr/bin/fluxbox to wherever your fluxbox binary is.



5. How do I add fluxbox to my KDM sessions menu.

There are a couple of ways. You can either choose the "default" session, which should load your .xsession file and thus you'd put "exec fluxbox" at the end of that.

Or, to get a fluxbox option, go into KDE Control Center and add a session type "fluxbox".

Or, edit your kdmrc file (probably /etc/kde2/kdm/kdmrc). Find the "SessionTypes=" line, and add fluxbox to the list.

If you are running Debian (thanks Dave Selby), then after adding the fluxbox session edit /etc/kde2/kdm/kdm.options and delete the line:

generate-sessiontypes

If you don't delete this Debian will loose the entry in the KDM menu when you reboot.

That should be enough. However, some older configurations require a little more effort - you may need to find your Xsession file (e.g. /etc/X11/Xsession, or /usr/X11R6/lib/X11/xdm/Xsession) and add an option in the case statement containing other WMs, i.e.

fluxbox)
exec fluxbox
;;

--------------------------------------------------------------

hope that helps.

Last edited by sandman; 10-29-2003 at 08:58 PM.
 
Old 10-31-2003, 08:18 PM   #5
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
I installed fluxbox recently but I think my system ignores files .xinitrc and .xsession. Point 4 of the documentarion helped me start fluxbox but now I want some programs to be run at startup and I don't know where to put them. I thought I should put them in one of those files but it doesn't work! Any idea?
 
Old 11-01-2003, 02:36 AM   #6
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Where did you put them in those files? Generally speaking, you should put them in your .xsession/.xinitrc file, and you must be sure to put it *before* the line 'exec fluxbox'

for example:
Code:
gkrellm &

exec fluxbox
Notice the ampersand (&) after the command. You have to background the process so that the script will continue on to the next command. Also notice that only the last command has exec placed before it, this is so that the script (and your X session) will stop when you close fluxbox.

You really should read the online documentation, especially this page:

http://fluxbox.org/docbook/en/html/app-setup.html

It explains it quite well, actually.

Enjoy!
--- Cerbere
 
Old 11-01-2003, 03:33 AM   #7
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
Like I said, my system is ingnoring .xinitrc and .xsession. I don't have any exec fluxbox because my system would ignore it. I added fluxbox to my GDM session and that's how I start fluxbox. I done this because those files are ignored...

My question is: why are those files beeing ignored and how can I change that
OR
what other file can I use to put command lines to be executed at startup.
 
Old 11-01-2003, 02:44 PM   #8
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
My guess would be to put them in the /etc/gdm/Sessions/fluxbox file, but again they should go before the 'exec fluxbox' line, and they should be followed by an ampersand.

Give it a shot, and let us know what happens.

BTW which programs do you want to start?

Enjoy!
--- Cerbere
 
Old 11-20-2003, 01:06 AM   #9
pandasonic
Member
 
Registered: Nov 2003
Location: Bronx, NY
Distribution: Fedora Core 3
Posts: 53

Rep: Reputation: 15
Hi.. I'm killin' myself trying to figure out how to make blackbox come up on the Sessions Menu on the Login Screen... I'm running Fedora Core 1

Does anybody have any idea of what i am supposed to do?... and if anybody does, please take into consideration the fact that i am a newbie and apparently an idiot because i tried some of the things i've read online but nothing seems to work...

thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting programs maximized in FluxBox mjjzf Linux - Software 1 10-16-2004 10:55 AM
Starting programs in Fluxbox or Windowmaker BajaNick Linux - Software 3 03-03-2004 02:31 AM
Starting Fluxbox.... AceTech747 Linux - Software 13 12-15-2003 05:02 PM
starting fluxbox in rh9.0 shiny Linux - Software 6 05-31-2003 01:44 PM
Starting Fluxbox rdanda Slackware 10 05-01-2003 01:58 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration