LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-27-2004, 07:57 PM   #1
WarlockofVirgo
Member
 
Registered: Mar 2004
Location: Toronto, Canada
Distribution: SUSE 9.1
Posts: 67

Rep: Reputation: 15
Question Starting Apache2


I just installed Apache2 on SuSE 9.1. Can some one tell me how to turn it on? I assumed once I installed the RPM from SuSE's ftp server that it would auto start for me and start when ever I booted up the computer or that I would have some kind of GUI I could click on in the start menu for the settings. I all ready figured out where to put my web site's files. All I need to know is how to turn it on and I'm good to go.
 
Old 07-28-2004, 02:52 AM   #2
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
At the command line, type: 'apachectl start'

For more info, go here.

Enjoy!
--- Cerbere
 
Old 07-29-2004, 09:00 PM   #3
WarlockofVirgo
Member
 
Registered: Mar 2004
Location: Toronto, Canada
Distribution: SUSE 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
When I try that I get the message...

bash: apachectl: command not found

What else should I do?
 
Old 07-29-2004, 09:05 PM   #4
millionknives
Member
 
Registered: Jul 2004
Location: Port Charlotte Florida
Distribution: slack 12.1
Posts: 78

Rep: Reputation: 15
Well.. Im not on suse and have little experiance with it but maybe its set for root only at the moment, I had to change the premissions for my apache so maybe that might be your problem (course sounds like your using a newer version then mine its about a year old still worth checking into that though)
 
Old 07-29-2004, 11:47 PM   #5
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
millionknives is correct that you must start apache as root, but I wouldn't follow his suggestion of changing permissions. It's far more secure to just su to root when you want to start/stop apache.

As for what else you should do . . . like I said before, go here. They go to a lot of trouble to write all that information down. The least you could do is read some of it.

Enjoy!
--- Cerbere
 
Old 07-29-2004, 11:58 PM   #6
millionknives
Member
 
Registered: Jul 2004
Location: Port Charlotte Florida
Distribution: slack 12.1
Posts: 78

Rep: Reputation: 15
See it worked fine for me and root to access but no one else could I just made it so that anyone could view and thats all worked for me so I thought Id sujest it and also, maybe I editied my apache and other things but it starts auto tho right as mine does.
 
Old 08-05-2004, 08:24 PM   #7
WarlockofVirgo
Member
 
Registered: Mar 2004
Location: Toronto, Canada
Distribution: SUSE 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
OK, I got it working. I ended up installing a RPM from the SuSE ftp server for adding a Apache2 module into YAST. After that I started up YAST and it was only a matter of clicking on a box to enable the Apache2 server. And no command line required. Thanks every for the help but I ended up figuring it out my self.
 
Old 08-11-2004, 03:11 PM   #8
proddi
LQ Newbie
 
Registered: Aug 2004
Posts: 4

Rep: Reputation: 0
i have the same problem: apache 2 won't start on suse 9.1. i haven't made any modifications after installing it.
could you specify exactly what you did that brought him to life?
thanx

Last edited by proddi; 08-11-2004 at 03:13 PM.
 
Old 08-12-2004, 01:40 AM   #9
WarlockofVirgo
Member
 
Registered: Mar 2004
Location: Toronto, Canada
Distribution: SUSE 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Open YaST, in the Software section click "Changed Source of Installation". Click Add, put mirror.mcs.anl.gov in "Server Name" and put pub/suse/i386/9.1 "Directory on Server". Click Ok and wait... Than click Finish.

Now Go back to the Software section and click "Install and Remove Software". Goto the box on the top left labeled "Filter", click in it and pick "Search". Under "Search In" and make sure all 5 boxes are checked. Goto the bottome middle and check the box that says "Autocheck". Go back to the top left to the Search field and type "apache2" (with out "'s) and hit enter or click search or what ever floats your boat.

Pick all the apache2 RPM's you want, I don't feel like listing them all. The one you really want is (scrowl all the way down) "yast2-http-server". That will add a thingy into Yast so you can some what configure Apache2 with a nice pretty GUI. Click Accept and install your sh*t.

Now go back YaST and goto the "Network Services" section. You should now see "HTTP Server" on the right seconded from the top so you should click that. Click "Enabled" at the top and check mark "Adapt Firewall" box. Click Finish and your good to go.
 
Old 08-13-2004, 12:44 AM   #10
proddi
LQ Newbie
 
Registered: Aug 2004
Posts: 4

Rep: Reputation: 0
thank you for your answer, but i had that Apache GUI already installed. my apache still fails to start, both at boot and when i try to start it from the command line. is it possible that another program is blocking my 80 port ? how can i check that out ?
 
Old 08-13-2004, 02:43 AM   #11
WarlockofVirgo
Member
 
Registered: Mar 2004
Location: Toronto, Canada
Distribution: SUSE 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
I couldn't say, I'm new to Linux my self. What SuSE are you using? Personal or Profesional and where did you get it? I got SuSE Personal from CompUSA. I installed the Apache RPM's from the SuSE site and they all work fine.

And also did you install any other daemons that may be listening on port 80?
 
Old 08-13-2004, 03:34 AM   #12
Sarinyo
LQ Newbie
 
Registered: Mar 2004
Posts: 16

Rep: Reputation: 0
Check ports

Hello, to check ports you should use the "netstat" command. See man pages for mor info, but I use "netstat -an" (all connections and no translate port number to services). You could use "netstat -putan" too (less info, but you'll see it if there is a dameon listening on port 80). You should check if there is a line like:

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 3348/httpd

Good luck with apache .

PS: You should take a look at your httpd.conf and set up some basics like domain, webmaster, etc. (Im not an apache expert!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot adjust 'apache2' service when starting Apache cbj4074 Linux - Software 7 11-18-2005 02:48 PM
apache2 not working: Starting httpd2 (prefork) fails _ktx Linux - Networking 2 03-30-2005 12:15 PM
Starting Apache2 using Service Command liaaam Linux - Software 2 06-14-2004 05:06 AM
starting apache2 on RH9 mjpuczko Red Hat 5 03-13-2004 02:45 AM
apache2 not starting :( jd121 Linux - Software 7 08-20-2003 12:37 AM


All times are GMT -5. The time now is 05:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration