LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-02-2005, 03:49 PM   #1
Shwiing
LQ Newbie
 
Registered: Jul 2005
Posts: 14

Rep: Reputation: 0
Start programs at startup and get rid of current saved session


Here are a couple questions of mine:

1) I have alltray and use it to open a borderless terminal window, I tried adding it under Preferences-> Sessions -> Startup Programs. But it didn't start up and no matter what order I change it to, it doesn't work.

2) I use gnome and one time before I shutdown I clicked "save current setup", now every time I boot up it opens the apps I had and all the info on my machine is back when I saved it. I wan't to delete this and have a new setup each time I boot, how do I do that?

Thanks,
Shwiing

Btw Im using Ubuntu linux (based off debian), with Gnome

Last edited by Shwiing; 08-02-2005 at 09:31 PM.
 
Old 08-03-2005, 01:21 PM   #2
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
I haven't used gnome in a long time, but I think there is a checkbox on the login screen (gdm) to save the current session.

To have a program run at startup you can add it to your /etc/init.d

I'm a little foggy on the details right now. Just search around for "/etc/init"

I'm sure you can set it up with a gnome gui also, but like I can't help you with that.
 
Old 08-04-2005, 02:14 AM   #3
Shwiing
LQ Newbie
 
Registered: Jul 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
I haven't used gnome in a long time, but I think there is a checkbox on the login screen (gdm) to save the current session.
Ya thats how it started, I found the solution: to login as failsafe go to .gnome2 folder and copy some failsafe files to the default files.

And after reading that u said to add to /etc/init.d I tried and it didnt work, then I realized I forgot to add sh before the location of my shell to boot the terminal so I added taht to the sessions and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Start Linux Programs Upon Booting - ie Windows' Startup? nathanield Linux - Newbie 4 12-18-2004 01:56 PM
How do I start programs on x startup? xscreensaver & gkrellm darkleaf Linux - Software 3 10-08-2004 05:15 PM
Session Save in Firefox--deleting saved sessions jonr Linux - Software 3 08-25-2004 02:22 PM
.xinitrc programs start twice on startup fasmaie Linux - Newbie 0 09-09-2003 04:59 PM
random saved GNOME session bluecadet Linux - General 1 12-31-2001 03:28 PM


All times are GMT -5. The time now is 10:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration