LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-06-2005, 11:55 AM   #1
Mr_Munkey
Member
 
Registered: Sep 2004
Distribution: Slackware Current
Posts: 33

Rep: Reputation: 15
SSHD Tweaks


Hello,

Some of my servers take a long time to ask me for the password when I put in the username when logging in through SSH. Is there a way to configure how long it waits to ask, or something to tweak it to be faster? It's taking like 10 to 15 seconds and is getting annoying

Thanks!
 
Old 01-06-2005, 03:01 PM   #2
y0shidono
LQ Newbie
 
Registered: Jan 2005
Distribution: FreeBSD
Posts: 2

Rep: Reputation: 0
when you ssh to the machine, do so with the verbose output:

ssh -v machinename

This could help you zero in on which step in the login process is holding up your connection, and remove it from your ssh_config (or ~/.ssh/config) file.
 
Old 01-06-2005, 06:38 PM   #3
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
Ahh, I remember having this mind boggling problem. Look at your resolv.conf file. Check that you have correct nameservers in there. If so, then you don't have a PTR record for that host you are trying to connect. Yes, when you read this you would be "uhh, no. My problem is with ssh, not DNS." They are related. .

Another way to handle this is in your sshd_config, change it to:
UseDNS no

-twantrd

Last edited by twantrd; 01-06-2005 at 06:45 PM.
 
Old 01-07-2005, 09:26 AM   #4
Mr_Munkey
Member
 
Registered: Sep 2004
Distribution: Slackware Current
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks for all the input. I actually didn't have UseDNS in the config file, and when I tried to put it in there OpenSSH didn't like it. I did find some information in the man pages that said to pass the "-u0" option when starting SSHD. This will cause it to not do reverse DNS checking for the logging at least. It is performing a lot better now.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Konqueror Tweaks? dresnu Linux - Software 2 04-15-2005 04:45 PM
Apache tweaks GEEF Linux - Security 1 01-14-2005 09:28 PM
Performance tweaks Cinder Debian 3 03-26-2004 06:49 AM
Enabling SSH in mandrake 9.2 - sshd vs. sshd-xinetd DogTags Linux - Newbie 7 11-25-2003 01:17 PM
Mandrake 8.0 tweaks Mandrunk Linux - Software 1 09-05-2001 07:45 PM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration