LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-09-2012, 08:39 PM   #1
kline
Member
 
Registered: Aug 2008
Location: Seattle
Distribution: Ubuntu
Posts: 74

Rep: Reputation: 0
ssh works outbound, but i get "no route to host" err inbound


guys,

i finally got past my bootloader problems [UEFI] on my new Dell 3010, and *finally* got KDE going. the major problem is ssh[d]. besides my server i have two boxes, ethos and tao. the problem is that i can do

% ssh ethos

from tao. i get to ethos in my /home/kline directory just fine. but when i try going back to tao:

% ssh tao

i get the port 22 error that there is "No route to host". of course i have googled around and even found a few [SOLVED] URL's. but nothing i do seems to resolve this prob. Any ideas?

thanks for any clues!

PS: sorry if i am re-asking. i got things working Once. my notes don't help, :(
 
Old 12-09-2012, 08:48 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,285
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
If you
Code:
ssh kline@ethos 'host tao'
and get a "NXDOMAIN" error back, would it be possible to set a static IP entry in /etc/hosts? Or do ethos and tao use dynamic addresses w/o possibility of mapping their MAC to a static IP address in whichever machine provides DHCP?
 
Old 12-09-2012, 11:10 PM   #3
kline
Member
 
Registered: Aug 2008
Location: Seattle
Distribution: Ubuntu
Posts: 74

Original Poster
Rep: Reputation: 0
host tao yields::

pts/5 20:49 <ethos> [4589] host tao
tao.thought.org has address 10.47.0.111

i've got a hardware firefall in a netgear box. this delivers the DHCP to all my tower cases and my laptops. moreover, i'm pretty sure the 10.47.0.111 is showing in the pf web software.

thanks, tho.

i'm about out of ideas. only a few things left, max.
 
Old 12-10-2012, 05:03 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,285
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
Quote:
Originally Posted by kline View Post
pts/5 20:49 <ethos> [4589] host tao
tao.thought.org has address 10.47.0.111
OK so the host name resolves properly. Is TCP/22 open on tao? You're not using a different port? And it's not firewalled? And it doesn't have PAM, /etc/ssh/sshd_config or /etc/hosts.{deny,allow} restrictions? If none of that post output of
Code:
ssh kline@ethos 'ssh -vvv kline@tao'
and also what syslogs say on tao, if anything.
 
Old 12-10-2012, 01:47 PM   #5
kline
Member
 
Registered: Aug 2008
Location: Seattle
Distribution: Ubuntu
Posts: 74

Original Poster
Rep: Reputation: 0
my entire domain is behind a hardware firewall. sshd is on everywhere: on tao, on ethos, and on my server. until last week when i reinstalled fedora-17, i was able to ssh either way from anywhere. reinstalling wiped tao clean, of course. i'm trying to figure out how to get ssh[d] working.

as for your code, the output is::


pts/6 11:39 <ethos> [4639] ssh kline@ethos 'ssh -vvv kline@tao' /tmp
kline@ethos's password:
OpenSSH_5.9p1, OpenSSL 1.0.0j-fips 10 May 2012
Pseudo-terminal will not be allocated because stdin is not a terminal.
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 50: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to tao [10.47.0.111] port 22.
debug1: connect to address 10.47.0.111 port 22: No route to host
ssh: connect to host tao port 22: No route to host

see anything here?
 
Old 12-10-2012, 03:33 PM   #6
kline
Member
 
Registered: Aug 2008
Location: Seattle
Distribution: Ubuntu
Posts: 74

Original Poster
Rep: Reputation: 0
problem SOLVED

WEll, it works. the thing i needed to check-mark was in system-config-firewall. yes, i had used this before when installing Gnome. but then i only checkmarked [x] SSH 22/tcp; this is listed under the "Trusted Services" section. it has the std bunch of unix stuff such as FTP, TFTP, etc.

Directly below the the "Trusted Services" selection is "Trusted Interfaces" where I found my fblunder. in there [right-hand side] is "eth+" which i thought is pretty obvious if you're trying to get out of one box on your network to another box. {Maybe the last time i had things working, i used the Wizard option. [?]} At any rate--actually, there are [2] at-any-rates: first, this time i have only been at it for a couple hours so my brain aint dead yet. second, i guess, is that it's obvious to investigate things that should-be obvious ... but *aren't*.

this time, because i did only One thing at a time, i'm pretty sure that check-marking the "eth+" box got things going.
 
Old 12-10-2012, 03:35 PM   #7
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,285
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
Well done fixing yourself, please mark thread "solved".
 
  


Reply

Tags
ssh, sshd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "No route to host" - ssh on fedora Inkit Linux - Newbie 6 11-04-2012 11:36 PM
"host" works, "dig" fails... what? dafydd2277 Linux - Networking 1 01-06-2012 04:10 PM
Linksys WRT54G, ssh, "no route to host" marnold Linux - Networking 1 09-29-2010 12:33 PM
shorewall routing issue: "no route to host" from dmz spargonaut Linux - Networking 0 06-07-2007 10:09 AM
Permanently set "route add" -host and default gw sacants Linux - Newbie 1 07-18-2003 04:04 AM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration