LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-18-2005, 10:15 PM   #1
clintonkerr
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian 3.1
Posts: 5

Rep: Reputation: 0
Question ssh wont connect outside of local network


I just started with linux this weekend and am having problems connecting to ssh via putty or winSCP from outside of my local network... It works fine using the standard 192.168.0.x ip, but when I try to connect from outside the network putty either closes immediatly or mentions something about the server closing the connection... I have the router configured to forward it to the machine on port 22... I've also tried runnung through port 8000 thinking that the isp may have blocked it or something... This doesn't seem to be the case though and was wondering if perhaps there is something I need to do on linux... I'm running Debian 3.1... I'm also having a similar problem with a Java server program I wrote for the linux machine... It works fine locally but has connection problems from the net... Any thoughts??? Thanks...
 
Old 09-18-2005, 10:36 PM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Is the destination host configured to serve SSH connection requests?

I'd check the following:
1. Verify you can do an ssh logon on the SSH server's local network (i.e. within it's firewall)
2. Make sure the server's firewall is open to incoming SSH connections (port 22, I believe).
3. Make sure your client's firewall is open to outgoing SSH connections.
 
Old 09-18-2005, 10:50 PM   #3
clintonkerr
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian 3.1
Posts: 5

Original Poster
Rep: Reputation: 0
yea everything works fine from behind the network firewall =/
 
Old 09-18-2005, 11:21 PM   #4
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Meaning that you've confirmed item "1". Please double-check any firewalls you're aware of at your end. Most have a GUI, and most GUI's have a little checkbox to enable SSH (i.e. you probably don't have do deal with iptables or IOS syntax or anything like that).

But it definitely sounds like "2" is the culprit: your server's firewall is probably blocking port 22.

Good luck .. PSM
 
Old 09-19-2005, 12:00 AM   #5
clintonkerr
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian 3.1
Posts: 5

Original Poster
Rep: Reputation: 0
Hmm, can't find an SSH checkbox... Perhaps I'm just being dense for even thinking this, but if a local firewall on the server were keeping it from working, wouldn't it keep it from working in the local network as well? Just wondering...

Thanks for your response btw
 
Old 09-19-2005, 12:08 AM   #6
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
No. In general, the firewall will inhibit connections between your LAN and some external LAN, but has absolutely no effect on any connections between any hosts within the LAN.

The fact that you're able to do SSH within your server's LAN is an important thing to know: it means the server itself is configured to "do SSH". This is *not* necessarily a given.

But, unfortunately, it doesn't shed too much light on why you can't open an SSH connection with that server from home.

Sorry I couldn't be of more help .. PSM

PS:
On your firewall settings, do you see *ANY* lists of ports it will/will not accept? If so, then perhaps there's someplace you can *ADD* a new port (i.e. add port 22 to that list). Just a thought...

Last edited by paulsm4; 09-19-2005 at 12:10 AM.
 
Old 09-19-2005, 12:10 PM   #7
clintonkerr
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian 3.1
Posts: 5

Original Poster
Rep: Reputation: 0
I don't see any firewall settings at all when searching the kde control center... The only thing under the firewall results are the proxy settings... Am I even looking in the right place? hehe I'm such a
 
Old 09-19-2005, 12:20 PM   #8
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
I think you've probably gone about as far as you can by yourself.

Your next step is to talk to your server's system administrator. He'd be able to tell you whether or not his firewall might be blocking SSH, he'd also be able to give you some intelligent and knowledgeable troubleshooting tips.

Good luck .. PSM
 
Old 09-19-2005, 11:26 PM   #9
clintonkerr
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian 3.1
Posts: 5

Original Poster
Rep: Reputation: 0
lol i am the server administrator =P... that's ok though I talked to someone today who showed me how to edit the ip tables... thanks for your help
 
Old 09-20-2005, 07:35 AM   #10
poochdog
Member
 
Registered: Jul 2004
Location: United Kingdom
Distribution: Fedora Core 9
Posts: 141

Rep: Reputation: 15
If you go to a terminal window and type lokkit, then choose to disable the firewall, you may be able to access the connection from the outside world then. If this works then configure it to allow incoming SSH...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can login to ssh via local network, but not outside brainlesspinkey Linux - Security 3 08-27-2005 04:12 PM
Samba: can't connect to my local linux machine but can connect to windows. Royle Linux - Networking 3 01-18-2005 05:32 PM
dnsmasq wont resolve local names without suffix Rooboy Linux - Networking 0 10-07-2004 06:46 AM
"connect: No buffer space available" in my local network area SpaceCowboy Linux - Networking 5 08-30-2004 02:44 AM
Cannot resolve local addresses on local network danielgrenyer Linux - Networking 6 01-14-2004 11:03 AM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration