LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-17-2008, 04:26 PM   #1
lumix
Member
 
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Rep: Reputation: 30
SSH login keeps failing, saying that "strict" mode is on. ...It isn't


On /etc/ssh/sshd_config I've tried strict mode ="no" and just commented out. Is this a client side thing?

Last edited by lumix; 12-17-2008 at 06:20 PM.
 
Old 12-17-2008, 06:17 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
Settings in sshd_config affect the SSH server (which runs as a dæmon process, hence the “d” suffix in sshd). i.e. settings here affect people attempting to log in to the computer that the sshd_config file is on. You may also need to restart SSH for changes here to take effect, typically with something like:
Code:
/etc/init.d/sshd restart
Also, strict_mode="no" is the correct setting to turn it off, according to a Google search: https://engineering.purdue.edu/ECN/m...er/000965.html

Client-side settings live in the ssh_config file instead.
 
Old 12-17-2008, 06:17 PM   #3
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Instead of turning off StrictModes, why not make your home directory permissions better (i.e. more restrictive)?

By the way, the directive is: StrictModes no

Read the manpages for sshd_config(5).

Last edited by anomie; 12-17-2008 at 06:19 PM.
 
Old 12-17-2008, 06:23 PM   #4
lumix
Member
 
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Original Poster
Rep: Reputation: 30
Whoops, thanks for the heads up...I meant strictmode="no".

I also did do a restart. After removing the known_hosts file (in the client .ssh dir), I was at last prompted for a password again. But Why? This is a client-side thing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 05:40 AM
"cant login, login incorrect"init : Id "x" respawning too fast:disabled for 5 minutes allenwoxx Linux - Newbie 1 11-21-2008 11:45 AM
How to disable remore ssh login access of "root" user. ashishshukla Linux - General 3 10-07-2008 09:55 AM
"Have to automate the SSH login procedure through shell scripting" sorav Programming 2 11-21-2007 05:53 AM
I am getting "MODE NOT SUPPORTED" message when i login to suse 9.3 RAHUKUMAR Linux - Hardware 11 01-05-2006 11:22 PM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration