LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-19-2010, 11:31 PM   #16
myubuntu
LQ Newbie
 
Registered: Feb 2010
Posts: 23
Blog Entries: 2

Original Poster
Rep: Reputation: 15

Quote:
Originally Posted by win32sux View Post
FWIW, this is what the installation looks like on my Ubuntu 8.10 box:
Code:
win32sux@candystore:~$ sudo apt-get install openssh-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  rssh molly-guard openssh-blacklist openssh-blacklist-extra
The following NEW packages will be installed:
  openssh-server
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 285kB of archives.
After this operation, 782kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com intrepid/main openssh-server 1:5.1p1-3ubuntu1 [285kB]
Fetched 285kB in 2s (114kB/s)          
Preconfiguring packages ...
Selecting previously deselected package openssh-server.
(Reading database ... 213706 files and directories currently installed.)
Unpacking openssh-server (from .../openssh-server_1%3a5.1p1-3ubuntu1_i386.deb) ...
Processing triggers for ufw ...
Processing triggers for man-db ...
Setting up openssh-server (1:5.1p1-3ubuntu1) ...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
 * Restarting OpenBSD Secure Shell server sshd                                                                                                        [ OK ] 

win32sux@candystore:~$ sudo netstat -pantu | grep LISTEN | grep ssh
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      19719/sshd      
win32sux@candystore:~$ sudo /etc/init.d/ssh restart
 * Restarting OpenBSD Secure Shell server sshd                                                                                                        [ OK ] 
win32sux@candystore:~$

Hey thanks for your reply & sorry for the delayed response. I did try to do the steps you have provided & the output shows that it listens in port 22.....if in future....say for example, I shutdown & restart the the Ubuntu machine......& wanted to restart the ssh....will there be the same prob??

Last edited by myubuntu; 02-19-2010 at 11:33 PM.
 
Old 02-19-2010, 11:34 PM   #17
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by myubuntu View Post
Hey thanks for your reply & sorry for the delayed response. I did try to do the steps you have provided & the output shows that it listens in port 22.....if in future....say for example, I shutdown & restart the the Ubuntu machine......& wanted to restart the ssh....will there be the same prob??
No, it'll start automatically when you reboot.
 
1 members found this post helpful.
Old 02-19-2010, 11:38 PM   #18
myubuntu
LQ Newbie
 
Registered: Feb 2010
Posts: 23
Blog Entries: 2

Original Poster
Rep: Reputation: 15
Post

Quote:
Originally Posted by win32sux View Post
No, it'll start automatically when you reboot.
I pretty sure last time infact 3 months back I did the same thing & I manually started.....it worked fine, recently I reinstalled the ubuntu...Its giving this issue, any ideas?? I had the same version 9.10 before & now
 
Old 02-19-2010, 11:46 PM   #19
myubuntu
LQ Newbie
 
Registered: Feb 2010
Posts: 23
Blog Entries: 2

Original Poster
Rep: Reputation: 15
Thumbs up

Quote:
Originally Posted by win32sux View Post
No, it'll start automatically when you reboot.
I pretty sure last time infact 3 months back I did the same thing & I manually started.....it worked fine, recently I reinstalled the ubuntu...Its giving this issue, any ideas?? I had the same version 9.10 before & now

Please let me know why its doing like if know.....But really thanks for your help & have a great day.
 
Old 02-20-2010, 02:00 AM   #20
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by myubuntu View Post
I pretty sure last time infact 3 months back I did the same thing & I manually started.....it worked fine, recently I reinstalled the ubuntu...Its giving this issue, any ideas?? I had the same version 9.10 before & now

Please let me know why its doing like if know.....But really thanks for your help & have a great day.
I haven't used 9.10 yet, but I couldn't imagine why the behavior would change by design. In any case, if this is a GUI box you can use the Services tool to manage the startup programs (I'm not sure if it's still called that in 9.10). On 8.10, it's accessible by going to System > Administration > Services. From the command line, you've got plenty of options (including manual editing of links). I've got sysv-rc-conf installed, which makes checks and tweaks very simple. Running a specific check for the SSH daemon I installed for illustrative purposes gives me (for example):
Code:
win32sux@candystore:~$ sudo sysv-rc-conf --list ssh
ssh          1:off	2:on	3:on	4:on	5:on
win32sux@candystore:~$
So I know the links for SSH are set for it to run unless I'm in single user mode (runlevel 1).

There's also GUI tools such as BUM available.

Last edited by win32sux; 02-20-2010 at 02:08 AM.
 
Old 02-22-2010, 11:32 PM   #21
myubuntu
LQ Newbie
 
Registered: Feb 2010
Posts: 23
Blog Entries: 2

Original Poster
Rep: Reputation: 15
Smile

Quote:
Originally Posted by win32sux View Post
I haven't used 9.10 yet, but I couldn't imagine why the behavior would change by design. In any case, if this is a GUI box you can use the Services tool to manage the startup programs (I'm not sure if it's still called that in 9.10). On 8.10, it's accessible by going to System > Administration > Services. From the command line, you've got plenty of options (including manual editing of links). I've got sysv-rc-conf installed, which makes checks and tweaks very simple. Running a specific check for the SSH daemon I installed for illustrative purposes gives me (for example):
Code:
win32sux@candystore:~$ sudo sysv-rc-conf --list ssh
ssh          1:off	2:on	3:on	4:on	5:on
win32sux@candystore:~$
So I know the links for SSH are set for it to run unless I'm in single user mode (runlevel 1).

There's also GUI tools such as BUM available.
Hey Pal, thanks for that info which I just checked, my apologies for delayed response. surely will let you know & if I need any help, Please respond.....
 
  


Reply

Tags
connection, host, port, refused, restart


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
curl: (7) couldn't connect to host // wget --> failed: Connection refused. linea Linux - Newbie 12 05-21-2012 12:56 PM
ssh: connect to host thyme1 port 22: Connection timed out - solved abstom Linux - Server 1 09-19-2009 05:33 AM
telnet: Unable to connect to remote host: Connection refused thomas2004ch Linux - Newbie 1 09-11-2009 02:51 AM
telnet: Unable to connect to remote host: Connection refused stuckz Fedora 6 06-21-2007 02:36 AM
telnet: Unable to connect to remote host: Connection refused stuckz Fedora - Installation 2 06-19-2007 09:21 AM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration