LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-11-2012, 10:54 PM   #1
cmccullo
Member
 
Registered: Jan 2011
Posts: 31

Rep: Reputation: 0
SServer and SClient not working


I built krb5-1.10.2 on two Ubuntu 12.04 desktop machines. I am trying to get sample/sserver to work on one and sample/sclient to work on the other. KDC, DNS, and NTP are working fine. I can get a ticket with kinit.

When I run ./sclient, I get
connected
sendauth rejected, error reply is: "Permission denied"

Syslog in the sserver machine has
sserver: recvauth failed--Permission denied

At this point, klist lists my ticket granting ticket krbtgt/REALM@REALM, and two tickets for the sample service, one sample/host.domain@REALM and one sample/host.domain@

It looks like I get connected, but when the authentication is checked, I fail. Do I have to do something to tell sserver who can access it?
 
Old 07-14-2012, 02:56 PM   #2
cmccullo
Member
 
Registered: Jan 2011
Posts: 31

Original Poster
Rep: Reputation: 0
Permission denied was fixed by changing permissions on /etc/krb5.keytab to 644.
Next I received Wrong principal errors. This was fixed by changing the contents of /etc/hostname. I only had the computer name, "host". I changed it to the FQDN, "host.domain.edu".
 
  


Reply

Tags
kerberos


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wifi not working in Eee PPC 1000HE (Debian Squeeze), but ethernet is working someshpr Linux - Laptop and Netbook 8 10-10-2011 03:59 PM
I want to set up ldap on my sserver sathish80 Linux - Newbie 1 01-27-2007 02:09 PM
Fortemedia FM801 card not working under FC5 on Intel 845 but working with windows morningkiran Linux - Hardware 0 11-30-2006 07:57 AM
acpi nearly working IBM thinkpad R40e 2684HVG no Fn key working, throttling OK Emmanuel_uk Linux - Laptop and Netbook 2 05-31-2006 01:41 AM
X sserver Problem neda_82 Linux - General 1 10-14-2002 05:26 AM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration