LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   squid slow response (http://www.linuxquestions.org/questions/linux-software-2/squid-slow-response-381033/)

ilnli 11-08-2005 05:34 AM

squid slow response
 
I have installed squid on my server the thing i've came across is the slow response of squid once if I open a site it takes time to resolve and established the connection and after that it works fine but why it take so much time when a site is opened.

however i've installed name server on the system for dns caching.

fouldsy 11-08-2005 06:10 AM

What does your /usr/local/squid/var/log/access show whilst the site is being requested? Is the object correctly cached? And what kind of delay are we talking about here? The faster your disks are, preferably SCSI drives in a RAID array, the more Squid likes it.

ilnli 11-08-2005 06:31 AM

no i am talking about the initial delay while establishing the connection once the connection of my browser is established then the response is quite fast

fouldsy 11-08-2005 07:53 AM

Right, okay, but still - what kind of delay are we talking about here? 1 second, 10 seconds, 2 minutes?

ilnli 11-08-2005 11:58 AM

its approximately 4 to 8 seconds and sometimes even more

zamri 11-08-2005 11:13 PM

for how long have u been using squid?

ilnli 11-09-2005 12:31 PM

its been more than a month.

zamri 11-10-2005 11:41 PM

how many users accessing te squid server?
what version of squid are u using?
Is there any antivirus used with squid?

ilnli 11-12-2005 08:40 AM

7 users
2.5.stable9
No Antivirus

zamri 11-19-2005 12:10 AM

i have no problem for my setup. been using it for about a year. u need to check ur squid and iptables rules. but then i am no squid or iptables guru. don;t know how to point u to the exact point of problem.

strasm 10-17-2006 12:56 AM

the fix
 
I have recently had this problem as well. I am sure that you have figured out what was wrong by now, but it seems like there are a lot of people looking for the answer but not finding it. There is a delay sometimes 10 seconds, once a page loads, other pages from that site load quicky. This is a DNS problem. In your squid.conf modify this line:

dns_nameservers xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy

Once this line points to your DNS servers your problem should be resolved.


All times are GMT -5. The time now is 08:17 AM.