LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   squid authentication with Active Directory (http://www.linuxquestions.org/questions/linux-software-2/squid-authentication-with-active-directory-622424/)

ashfaq 02-20-2008 03:28 AM

squid authentication with Active Directory
 
i have configured squid authenticatin with Active Directory and its working ok my problem is that whenever i open a browser from client it asks for username/password although i am logged on to the domain from which i am authenticed..
pl give me any solution if u have..
thanks...

weisso5 02-21-2008 12:01 PM

Is your squid machine bound to the domain?

ashfaq 02-21-2008 10:56 PM

ldap configured no idea about bound with domain
 
thanks for the reply...
i have configured my squid to authenticate with AD...for that i use the following configuration with my domain parameters:

auth_param basic program /usr/lib/squid/ldap_auth -R
-b "dc=vm-domain,dc=papercut,dc=com"
-D "cn=Administrator,cn=Users,dc=your,dc=domain,dc=com"
-w "password" -f sAMAccountName=%s -h 192.168.1.75
auth_param basic children 5
auth_param basic realm Your Organisation Name
auth_param basic credentialsttl 5 minutes

and also make an external acl in squid to allow..authenticated users..
... is there any thing else i have to do...

weisso5 02-22-2008 10:23 AM

Unless the machine is bound to the domain, you are going to get a prompt for username and password. Please confirm that you have bound this machine to your domain.

ashfaq 02-24-2008 10:44 PM

thanks for reply...
i am sorry i have no idea about how to bound my machine to domain..
will u please tell me how to check this out...

ashfaq 02-25-2008 01:23 AM

hi ..
if u are talking about the domain joining...
then yes.. my clinet is the part of domain controller and it is logged on to domain.. but still asking for username and password..whenever i open a new browser..
but if i open browser through ctrl+n it doesn't ask for username, password..
...
what to do...

weisso5 02-26-2008 10:26 AM

Can you post your entire squid.conf

That way i can try and solve all your questions.


thanks,
weisso

ashfaq 03-13-2008 11:56 PM

hi
 
hi have u got any thing for me..
i have sent my squid.conf to u...
... just tell me how to bound my linux machine on which squid is running with my domain controller..
your response will be highly appreciated.
thanks.

weisso5 03-14-2008 02:26 PM

I don't know where you sent it too... Can you please post it here.

thanks,
weisso


All times are GMT -5. The time now is 06:07 AM.