LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-31-2002, 09:08 AM   #1
pk21
Member
 
Registered: Jun 2002
Location: Netherlands - Amsterdam
Distribution: RedHat 9
Posts: 549

Rep: Reputation: 30
Squid


Hi all.
I have made a proxy server and nowthe users get the following error when they connect to an ftp site using internet explorer.

The error they get in a popup box: The folder'ftp://ftp.planet.nl/' is read-only because the proxy server is not set up to allow full access.
 
Old 12-31-2002, 10:29 AM   #2
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
proxy servers can't handle uploads via ftp.

you can disable this popup in IE in the options where it says "enable ftp folder view" or something

If you need to upload you have to setup some NAT or forwarding on your firewall.
 
Old 01-02-2003, 04:16 AM   #3
pk21
Member
 
Registered: Jun 2002
Location: Netherlands - Amsterdam
Distribution: RedHat 9
Posts: 549

Original Poster
Rep: Reputation: 30
Ok, thanks.

Any idea on how to do this? Looks like a lot of work
 
Old 01-02-2003, 04:30 AM   #4
niknah
Member
 
Registered: Dec 2002
Location: In front of a computer
Distribution: UPS, DHL, FedEx
Posts: 466

Rep: Reputation: 38
This is only needed if you want to upload to ftp servers, if you only want to download via ftp just disable the folder view in IE.

do enable ftp forwarding on your proxy type...

echo 1 >/proc/sys/net/ipv4/ip_forward
/sbin/iptables -A FORWARD -s x.x.x.x/24 -d 0.0.0.0/0 -j ACCEPT
/sbin/iptables -p tcp -t NAT -A POSTROUTING -j SNAT -s x.x.x.x/24 -d 0.0.0.0/0 --dport 20:21 --to-source y.y.y.y
/sbin/iptables -p udp -t NAT -A POSTROUTING -j SNAT -s x.x.x.x/24 -d 0.0.0.0/0 --dport 20:21 --to-source y.y.y.y


where x.x.x.x is your network and 24 is your netmask.
and y.y.y.y is your outside ip address that the isp gave you.
 
Old 01-02-2003, 08:15 AM   #5
pk21
Member
 
Registered: Jun 2002
Location: Netherlands - Amsterdam
Distribution: RedHat 9
Posts: 549

Original Poster
Rep: Reputation: 30
Thanks, ill give it a try.

They have to upload for some sort of moneytransfering program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SQUID for blocking yahoo and msn [inc squid.conf] chrisfirestar Linux - Security 10 03-03-2008 09:33 AM
squid message customization, hiding squid versioin rajnishmishra Linux - Networking 0 11-27-2004 04:55 AM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 03:29 PM
I can't "service squid start" , and chkconfig squid on not working Niceman2005 Linux - Software 0 11-10-2004 09:18 PM
Squid load testing software / Squid optimisation? gundelgauk Linux - Networking 2 08-31-2004 08:36 PM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration