LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-10-2003, 10:46 PM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
Spice3 deps


[root@betty src]# rpm -ivh spice-3f4-4.i386.rpm
error: failed dependencies:
libreadline.so.3 is needed by spice-3f4-4
[root@betty src]# rpm -ivh --nodeps spice-3f4-4.i386.rpm
Preparing... ##################################### [100%]
1:spice ##################################### [100%]
[root@betty src]# spice3
spice3: error while loading shared libraries: libreadline.so.3: cannot open shared object file: No such file or directory

This is what I get when I try to force the installation of spice3 for linux. Before I forced the RPM install, I installed the readline packages. The readline package I installed included the libreadline.so.3 file. How do I point the program to the correct place to the shared library? I really need this program to work.
 
Old 05-11-2003, 02:59 AM   #2
nakkaya
Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
looks like they were in a diffrent path in the machine which readline was compiled download another readline and install it try installing it again? and did you look at the file inside the read line to make sure it includes that file?
 
Old 03-21-2006, 12:36 PM   #3
kumarpraveen
LQ Newbie
 
Registered: Mar 2006
Location: India
Distribution: Fedora Core 3
Posts: 4

Rep: Reputation: 0
SPICE in Fedora Core 3 : cann't load shared file libreadline.so.3

Quote:
Originally Posted by mrsolo
[root@betty src]# rpm -ivh spice-3f4-4.i386.rpm
error: failed dependencies:
libreadline.so.3 is needed by spice-3f4-4
[root@betty src]# rpm -ivh --nodeps spice-3f4-4.i386.rpm
Preparing... ##################################### [100%]
1:spice ##################################### [100%]
[root@betty src]# spice3
spice3: error while loading shared libraries: libreadline.so.3: cannot open shared object file: No such file or directory

This is what I get when I try to force the installation of spice3 for linux. Before I forced the RPM install, I installed the readline packages. The readline package I installed included the libreadline.so.3 file. How do I point the program to the correct place to the shared library? I really need this program to work.

Has anybody found the way to do this. If yes, please let us know. I'm also facing the same difficulty.

Regards
Praveen

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install spice3 age Linux - Software 8 10-04-2005 10:52 AM
courier deps Pebcak Debian 7 06-27-2005 05:54 PM
Spice3 trouble -- Help, please? ki6sz Linux - Software 1 11-11-2004 07:08 PM
The Secret to Deps Diode Linux - Software 3 02-12-2004 12:57 PM
glib 2.2.3 and deps. Lindy Linux - Software 0 12-07-2003 04:26 PM


All times are GMT -5. The time now is 11:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration