LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-20-2006, 11:44 PM   #1
The_Nerd
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
Soundcard doesn't work until I run system-config-soundcard


I have this very strange problem after installing the new motherboard I just bought. My sound doesn't work at all until I run "system-config-soundcard". However, just running it isn't enough, I have to push the "Play test sound" button, it plays it's little sound, and then the whole system is happy afterwards. Why? I've looked at the modules loaded into the kernel, and they look fine. I've even manually tried inserting the right one, but no effect. I've also tried restarting ARTSD. My system is thus:

AMD Althon 3500+
Fedora Core 3, kernel 2.6.11-2

Soundcard detection utility gives the following info:
Vendor: nVidia
Model: Corporation nForce3 250Gb AC'97 Audio Controller
Module: snd-intel8x0

My motherboard is an ECS Elitegroup nForce3.

Anyone know what's wrong?
 
Old 01-21-2006, 03:47 PM   #2
halvy
Member
 
Registered: Aug 2005
Location: Boston Massachussets, USA
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 893

Rep: Reputation: 41
run alsaconfig, it will safe your settings.
 
Old 02-11-2006, 09:53 AM   #3
royalfox
LQ Newbie
 
Registered: Jun 2005
Location: Omaha, NE
Distribution: Fedora Core
Posts: 5

Rep: Reputation: 0
Smile

alsaconfig isn't on my system. I did a package scan with yum and concluded it is an out-dated utility (I'm using alsa drivers V1.0.10). Prior to scanning with yum, I found alsaunmute on my system and gave it a try and that's all it took to make my sound card work .

In order to make this permanent, I added:
/usr/bin/alsaunmute 0
to the final line in the start section of my /etc/init.d/alsasound init script (My card is card 0. I imagine in a 2-soundcard system, second card is card 1, adjust for your configuration). I now have sound following a reboot without running system-config-soundcard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcard Driver for ALi M5451 Soundcard (Trident Module) xianzai Linux - Hardware 3 12-15-2006 12:00 PM
how to run system-config-soundcard automatically during starting process? leduytien Linux - Software 1 02-11-2006 09:57 AM
Run Config Tool for Soundcard on Harddrake doesn't work iodax Linux - Hardware 2 09-13-2004 05:34 AM
I need to run system-config-soundcard to get audio Teus Fedora 0 06-06-2004 10:41 AM
firstboot, redhat-config-soundcard won't run Aeiri Linux - Software 2 02-28-2004 01:27 PM


All times are GMT -5. The time now is 07:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration