LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-21-2003, 07:20 PM   #1
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Rep: Reputation: 30
Sound went from good to bad


I noticed that what used to be great sound on my Linux box just got pretty bad. XMMS, games and everything else just started sounding bad right at once. I think I might know what caused it however, but I have no Idea how to fix it. Earlier this week I downloaded a copy of the UT2003 Demo for Linux. The sound was pretty bad so I looked in the readme. It told me to tyoe in the terminal:

echo "(define devices '(sdl))" > ~/.openalrc

I looked in my /home/Austin/.openalrc file and found (define devices '(sdl)) in there. I dont know how to change it back and I'm afraid to jusr delete the line.
Would this affect my sound at all? I'm assuming this tells the program 'openalrc' to use 'sdl' as the sound device. Is openalrc used for all sound? If so, that is probably why I noticed the change. Maybe someone knows how to reset it to it was before? Thanks in advance

I use: Red Hat 8.0
Creative SoundBlaster Live! value edition

if you need to know anything else just ask

Last edited by Fingel; 03-21-2003 at 07:23 PM.
 
Old 03-21-2003, 07:31 PM   #2
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Re: Sound went from good to bad

Quote:
Originally posted by Fingel
The sound was pretty bad so I looked in the readme. It told me to tyoe in the terminal:

echo "(define devices '(sdl))" > ~/.openalrc

I looked in my /home/Austin/.openalrc file and found (define devices '(sdl)) in there. I dont know how to change it back and I'm afraid to jusr delete the line.
The command you issued obliterated anything that might have been in any existing .openalrc. So I wouldn't worry about deleting the line.
Quote:
Would this affect my sound at all? I'm assuming this tells the program 'openalrc' to use 'sdl' as the sound device. Is openalrc used for all sound? If so, that is probably why I noticed the change. Maybe someone knows how to reset it to it was before?
Oddly, I saw the same thing some time ago and tried it and I, too, noticed the same thing about sound quality: it stunk. I solved the problem with the following command:

mv .openalrc .openalrc.breaks_things

Since then I find that sound works just fine. I'm using Creative PCI512 (IIRC using the same chipset as the Live!) and the ALSA driver.
 
Old 03-21-2003, 08:32 PM   #3
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
this isn't good, I renamed the file but there is no difference. Maybe it dosnt have anything to do with openalrc?
This really makes me mad too. I'm a big music fan.

Last edited by Fingel; 03-21-2003 at 08:34 PM.
 
Old 03-21-2003, 09:02 PM   #4
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
Excerpt from the Ut2003 readme

Q: I don't get any sound, and/or audio output is very messed up.
A: We use OpenAL for sound output. The included OpenAL is compiled
with support for direct writes to /dev/dsp using the Open Sound
System API provided by the kernel, and support for playback through
SDL.Some systems may have buggy drivers or perhaps have the audio
device captured by the esound or arts daemons. SDL is very good at
handling the whole range of audio solutions and workarounds, and
since we ship with SDL anyhow, it makes sense to use it as a
fallback.


The short answer is this:

echo "(define devices '(sdl))" > ~/.openalrc

That will coerce OpenAL to use SDL for audio output, which will
solve 99% of the problems you might be having. SDL can be
directed to use various audio targets with an environment
variable, if it doesn't magically pick the right one.

Notice the bold lines, does anyone know how to undo that? I think I used to use either arts or esound. I want them back!!!!
 
Old 03-22-2003, 12:35 AM   #5
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Quote:
Originally posted by Fingel
Notice the bold lines, does anyone know how to undo that? I think I used to use either arts or esound. I want them back!!!!
If you go into (I'm using Gnome so I'll refer to that menu) Preferences -> Sound you can tell the desktop manager to start a sound daemon at startup. If that checkbox isn't, um, checked, then you can check it and log off and back on again.

I read that blurb in the readme as the UT folks saying that esd and/or artsd was getting in the way, somehow, with the way UT2003 was trying to access the sound device. If you disable it in the menu and then kill any running sound daemon, perhaps your sound situation will improve in the game. I'm not seeing any problems having esd running when I start the game, though. Could be an ALSA vs. OSS problem.

Not sure if this could be something to pursue or not but are you running the game in a window or full-screen?
 
Old 03-23-2003, 11:08 AM   #6
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
It has arts checked, but it still is bad. And I can see the arts deamon running im my process table. Anyway, I'm not worried about the sound in UT at all, I just want the sound for everything else to be working fine again. But if your wondering I play in Full Sceen.
 
Old 03-23-2003, 11:40 AM   #7
acid2000
Member
 
Registered: Nov 2001
Location: Exeter, UK
Distribution: Gentoo 1.4
Posts: 243

Rep: Reputation: 30
I doubt it is unreal tournament, start up in run level 3 and run mp3blaster and see if the sound is ok, run as root and not the normal user that way any user processes shouldn't get started.
 
Old 03-23-2003, 11:54 AM   #8
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
good idea. I know its not UT that did it, but It could be that line it told me to change in openalrc. I'll donload mp3blaster now and try that out.
 
Old 03-23-2003, 12:21 PM   #9
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
Ok bad news. I tried mp3blaster in run level 3 as root and my regular user. It still sounds like crap. Are there any diagnostics programs I could prbably try out? I have soundblaster live! value edition sound card.
This is frustrating because I've had great sound in linux for a long time, and now it just sounds bad.
 
Old 03-23-2003, 01:22 PM   #10
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Quote:
Originally posted by Fingel
It has arts checked, but it still is bad. And I can see the arts deamon running im my process table. Anyway, I'm not worried about the sound in UT at all, I just want the sound for everything else to be working fine again.
Hmm... I remember running esd even with KDE (started outside KDE during boot) because arts was so flaky (it died dumping core an awful lot back in RH7.1; esd never did). Have you tried running Gnome to see if sound behavior improves or at least changes? That might isolate the problem to artsd vs. esd. If it's equally bad in either, I'd suspect the underlying driver.

But don't overlook the really silly causes as well. I recently had a problem with the right channel having reduced volume and containing a lot of static. After mucking around with all the mixer settings I could think of, it turned out that the problem was the audio connector to the spealers on the back of the card had become partially unplugged. (Now I'm looking for a way to clamp the cables down with a strain relief. :-) )
Quote:
But if your wondering I play in Full Sceen.
Just curious. I tried the game in a windows -- mainly to see how it worked -- and the mouse was horribly erratic making the game pretty much unplayable. I can't remember if sound was affected or not since I was concentrating on trying to get the mouse to work.
 
Old 03-23-2003, 02:14 PM   #11
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
well I tried gnome, same bad sound. Tried KDE without arts, same bad sound. I tried kde without arts but used esound, still sucks. What could have caused my sound work perfectly then randomly one day just go bad? The only thing I can remember is installing Mplayer.
that and the whole echo "(define devices '(sdl))" > ~/.openalrc thing
 
Old 03-23-2003, 05:33 PM   #12
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Quote:
Originally posted by Fingel
well I tried gnome, same bad sound. Tried KDE without arts, same bad sound. I tried kde without arts but used esound, still sucks. What could have caused my sound work perfectly then randomly one day just go bad? The only thing I can remember is installing Mplayer.
that and the whole echo "(define devices '(sdl))" > ~/.openalrc thing
Wow! I'd suspect the driver if that was part of something that you might have upgraded (via RHN perhaps?) since that would be common to both situations. I don't have a great deal of experience with the OSS driver supplied with the kernel. I switched to ALSA back in RH7.1, tried OSS w/ RH8, and switched back to ALSA but all that was with an older card. Stayed with that driver when I bought the PCI512. I have installed mplayer as well and it didn't have any affect on the sound. And you're sure that no hardware changes were made? Or BIOS changes? I have a hard time believing that you could have a corrupted sound module but I suppose checking the time stamps on the modules couldn't hurt (looking for any modules changed on the day you noticed the crummy sound.) If you're dual booting you could see if Windows is able to play sounds properly. If not, then perhaps the card is hosed.
 
Old 03-23-2003, 06:04 PM   #13
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
hmm, maybe it is something I upgraded through RHN. I just wouldent remember what it was. Should I give alsa a try? Would ALSA take over the work of arts and esound etc? My sound card works fine in windows I havent messed witht he bios or any modules.
 
Old 03-23-2003, 06:21 PM   #14
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Quote:
Originally posted by Fingel
hmm, maybe it is something I upgraded through RHN. I just wouldent remember what it was. Should I give alsa a try? Would ALSA take over the work of arts and esound etc? My sound card works fine in windows I havent messed witht he bios or any modules.
Sure sounding like something might have gotten messed up by an RHN ``upgrade''. Do you recall performing one of these just before the sound went awry? As for ALSA taking over for artd/esd? No. I'm still using esd on top of the ALSA driver. So far no complaints. BTW, there is another driver available (from Creative it appears) that you could try. I have no experience with it. I heard about it via a thread on LQ. A search for ``emu10k1'' would probably track it (them) down. The site for this driver project is SourceForge .
 
Old 03-23-2003, 08:35 PM   #15
Fingel
Member
 
Registered: Feb 2003
Location: 127.0.0.1
Distribution: Latest Ubuntu
Posts: 161

Original Poster
Rep: Reputation: 30
I already have the emu10k1 drivers installed, they came with redhat. I wanted to know If I could use ALSA Instead of esound or arts just to see if maybe it would help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
knoppix-good or bad? digitalmastermind Debian 16 10-24-2005 04:31 PM
Linux good/bad colinstu Linux - Software 22 06-03-2005 11:33 AM
Mandrakesoft's new name: good or bad? snecklifter Mandriva 22 04-21-2005 09:40 AM
Is this a good or bad idea? kemplej Linux - Software 2 10-26-2004 10:34 AM
sound - good & bad 9nine9 Linux - Hardware 0 12-03-2002 10:59 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration