LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Sound kernel module errors with FC4 since kernel 2.6.14 (http://www.linuxquestions.org/questions/linux-software-2/sound-kernel-module-errors-with-fc4-since-kernel-2-6-14-a-393412/)

knutdc 12-15-2005 11:21 PM

Sound kernel module errors with FC4 since kernel 2.6.14
 
I have been happily running Fedora Core 4 for several months, regularly upgrading all installed packages nightly with yum. I had no problems with sound through kernel-2.6.13-1.1532_FC4. With every kernel update after that (2.6.14-1.1637_FC4, 2.6.14-1.1644_FC4, and 2.6.14-1653_FC4), the kernel module for my sound card, which is based on the CMI 8738 chip, refuses to load and I get no sound. Any attempt to modprobe the snd_cmipci module results in a long list of "undefined symbol" and "invalid argument or parameter" messages. Obviously, some things didn't get properly linked when the newer kernel packages got compiled and installed.

Fortunately, kernel-2.6.13-1.1532_FC4 is still installed on my machine and it still produces sound. I'm a little surprised that upgrading "stock" FC4 kernel packages would break the configuration for a common piece of hardware like a CMI 8738 sound card. I've considered setting up a kernel source tree for a newer kernel package and recompiling just to make sure that the necessary features have in fact been included, but I'd just as soon avoid the extra work if someone can suggest an easier route to take.

Thanks for any hints anyone might have.

320mb 12-23-2005 02:40 PM

Quote:

Originally Posted by knutdc
regularly upgrading all installed packages nightly with yum. Obviously, some things didn't get properly linked when the newer kernel packages got compiled and installed.

Are you using KDE??? and if so, did the aRts AND/OR the Alsa package/s get updated properly?? you may just have to do it manually just to be sure.........

knutdc 12-23-2005 07:53 PM

Well, I do have the basic KDE packages installed and the KDE games, but I use the Gnome desktop. FWIW, I have the following alsa packages installed:

alsa-utils-1.0.10-1.FC4
alsa-lib-1.0.10-2.FC4
alsa-lib-devel-1.0.10-2.FC4

I do not have aRts installed. Following are my KDE packages:

kdebase-3.5.0-0.1.fc4
kdelibs-3.5.0-0.1.fc4
kdegames-3.5.0-0.1.fc4

Also, the KDE games seem to work as expected (with sound) as do all others when I boot with the 2.6.13-1.1532_FC4 kernel. Anyway, thanks for your reply!

Darron


All times are GMT -5. The time now is 08:26 AM.