LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-17-2004, 11:36 AM   #1
spotslayer
Member
 
Registered: Nov 2003
Location: Texas
Distribution: SuSE
Posts: 128

Rep: Reputation: 15
Sound in Video players


I am using SuSE 9.1 pro and I have been using MPlayer and Xine for several months with no problems. I tried to view a movie last evening and there was no sound, only a severe buzzing. This happens with both MPlayer and Xine. If I run from the command line this is the output.

=============================================================

david@BigD:~> gmplayer
MPlayer 1.0pre5-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 2394 MHz (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/david/.mplayer/config
[cfg] read config file: /home/david/.mplayer/gui.conf
Reading config file /home/david/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/david/.mplayer/codecs.conf: 73 audio & 180 video codecs
Font /home/david/.mplayer/font/font.desc loaded successfully! (206 chars)
Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Using usleep() timing
Input config file /home/david/.mplayer/input.conf parsed: 53 binds
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/david/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[gui] add video filter: pp

Playing /home/david/movies/LionKing 1 1%2f2.avi.
Cache fill: 4.20% (352256 bytes) AVI file format detected.
VIDEO: [DIVX] 480x282 24bpp 29.970 fps 831.1 kbps (101.5 kbyte/s)
Clip info:
Software: MEncoder 1.0pre5-3.3.3
Source Form: DVD ripped by acidrip.sf.net
==========================================================================
Trying to force audio codec driver family ffmpeg...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 12000->192000 (96.0 kbit)
Selected audio codec: [ffmp3] afm:ffmpeg (FFmpeg MPEG layer-3 audio decoder)
==========================================================================
Opening video filter: [pp]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
[PP] Using external postprocessing filter, max q = 6.
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
[pl_volnorm] Normalizer plugin in use.
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [plugin] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 480 x 282 (preferred csp: Planar YV12)
[PP] Using external postprocessing filter, max q = 6.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.70:1 - prescaling to correct movie aspect.
VO: [xv] 480x282 => 480x282 Planar YV12
ALSA lib control.c:654snd_ctl_open_noupdate) Invalid CTL /dev/mixer13%
alsa-control: mixer attach /dev/mixer error: No such file or directory
ALSA lib control.c:654snd_ctl_open_noupdate) Invalid CTL /dev/mixer99%
alsa-control: mixer attach /dev/mixer error: No such file or directory
ALSA lib control.c:654snd_ctl_open_noupdate) Invalid CTL /dev/mixer99%
alsa-control: mixer attach /dev/mixer error: No such file or directory
ALSA lib control.c:654snd_ctl_open_noupdate) Invalid CTL /dev/mixer99%

I have a /dev/mixer and I have rw rights to it.

Music with XMMS and all other music players work without problem. I would really like to be able to hear the videos as I watch. Don't know how I broke it, but need help to fix it.

Thank's
David
 
Old 10-17-2004, 11:42 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
ok, well it looks like an also problem. if you run "mplayer file.avi -ao oss" does that play ok? (or arts or esd, depending on your X preferences) have you messed with alsa recently? kernel recompile?
 
Old 10-17-2004, 12:16 PM   #3
spotslayer
Member
 
Registered: Nov 2003
Location: Texas
Distribution: SuSE
Posts: 128

Original Poster
Rep: Reputation: 15
You are absolutly correct Chris. OSS, arts, esd all work without problem. I have not messed with alsa or any kind of recompile. I don't know what made it go south. Since the problem occurred I have been crawlin around and haven't seen a problem. I reinstalle all the rpm's before I posted and had the same results. Do you have a suggestion for me?

David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
any mpeg video players LinuxPadawan Linux - Software 4 04-03-2005 02:11 PM
Help!! Video players not working lightkuragari Slackware 2 01-31-2005 03:46 PM
Help about Video Players.. explosive Linux - Software 0 08-29-2004 12:34 AM
Video players gabebster Linux - Software 2 07-23-2003 12:21 PM
Video Players help Mack Linux - Software 2 01-12-2003 05:21 PM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration